Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SOLVED: Enabled 'Stereo Mix' in Conexant HD Audio in Windows 10


  • Please log in to reply
2 replies to this topic

#1 mark_4-18

mark_4-18

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:59 PM

Posted 17 October 2016 - 12:56 AM

After upgrading from Win 7 to Win 10, on a TOSHIBA Satellite C655-S5212 laptop, I lost everything in the 'Recording Devices' window (Control Panel \ Sound, then open the 'Recording' tab) except the internal microphone, even with the "Show Disabled Devices" & "Show Disconnected Devices" BOTH checked.

 

With Win 7, I had solved this problem with the instructions by poster 'wildzero' found at this previous 'bleepingcomputer.com' thread:

 

http://www.bleepingcomputer.com/forums/t/502384/conexant-smartaudio-hd-sound-card-enable-stereo-mix/

 

But after the Win 10 upgrade, I had trouble locating the .INF file that had to be edited to gain the 'Stereo Mix' back to being visible, because the Conexant HD Audio driver was different, hence the folder and file name had changed, from the Win 7 OS.

 

Also worth noting here, is that the Conexant HD Audio driver I was dealing with is 64 bit  v8.54.49.50

 

On the TOSHIBA laptop (Satellite C655-S5212), it ended up being a file named CALCC2WA.inf, located inside the C:\Windows\System32\DriverStore\FileRepository\CALCC2WA.inf_amd64_07118bd8a2180658 folder.

Find and open (with Notepad) the "CALCC2WA.inf" file inside that folder.

 

BUT ... You must FIRST change the permissions of this file to save the editing, otherwise you'll get a pop-up window telling you that you don't have permission to alter this file. Do this by 'right-clicking' on the file, and click 'Properties,' then click the 'Security' tab at the top of the 'Properties' pop-up window.

 
Then make sure all of the 'Allow' boxes are checked for each Group/user name in the upper part of the 'Permissions' window, then click 'Apply' at the bottom of the 'Permissions' window, and exit.

 

Once 'Permissions' are allowed, click the "Edit" tab at the top-left of the Notepad app window, and then find and click either "Find..." or "Find Next" in the drop-down window.

 

I just entered "stereo" in the 'Find' box, and then clicked 'next.' It took me right to these three lines:

 

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01
;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0
;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00
 
Remove the 'semi-colons' from the front of each line, so they now look like this:
 
HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01
HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0
HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00
 
If you successfully changed the 'Permissions', you should then be able to 'save' the editing you have done, and close the Notepad app.
 
Then (I didn't do this, but...) you should probably reset the 'Permissions' settings back to their previous state, for the "CALCC2WA.inf" file.
 
If you have successfully accomplished all of this up to this point, the next step is to go to the 'Device Manager' in the Control Panel, and find your Conexant HD Audio device in there, and uninstall the drivers for it ... DO NOT select or check the box labelled "Delete the driver software for this device"  ... only 'uninstall.' If it is already 'checked' then 'UN-check' it.
 
Then restart your computer, and you should be able to find the "Stereo Mix" device in 'Control Panel \ Sound \ Recording tab' ... IF ... you have already right-clicked inside the box under the 'Recording' tab and checked "Show Disabled Devices" & "Show Disconnected Devices."
 
 
I hope this works for you as well as it did for myself.

Edited by mark_4-18, 17 October 2016 - 01:05 AM.


BC AdBot (Login to Remove)

 


#2 JohnB47

JohnB47

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:59 PM

Posted 18 December 2016 - 01:20 PM

 

After upgrading from Win 7 to Win 10, on a TOSHIBA Satellite C655-S5212 laptop, I lost everything in the 'Recording Devices' window (Control Panel \ Sound, then open the 'Recording' tab) except the internal microphone, even with the "Show Disabled Devices" & "Show Disconnected Devices" BOTH checked.

 

With Win 7, I had solved this problem with the instructions by poster 'wildzero' found at this previous 'bleepingcomputer.com' thread:

 

http://www.bleepingcomputer.com/forums/t/502384/conexant-smartaudio-hd-sound-card-enable-stereo-mix/

 

But after the Win 10 upgrade, I had trouble locating the .INF file that had to be edited to gain the 'Stereo Mix' back to being visible, because the Conexant HD Audio driver was different, hence the folder and file name had changed, from the Win 7 OS.

 

Also worth noting here, is that the Conexant HD Audio driver I was dealing with is 64 bit  v8.54.49.50

 

On the TOSHIBA laptop (Satellite C655-S5212), it ended up being a file named CALCC2WA.inf, located inside the C:\Windows\System32\DriverStore\FileRepository\CALCC2WA.inf_amd64_07118bd8a2180658 folder.

Find and open (with Notepad) the "CALCC2WA.inf" file inside that folder.

 

BUT ... You must FIRST change the permissions of this file to save the editing, otherwise you'll get a pop-up window telling you that you don't have permission to alter this file. Do this by 'right-clicking' on the file, and click 'Properties,' then click the 'Security' tab at the top of the 'Properties' pop-up window.

 
Then make sure all of the 'Allow' boxes are checked for each Group/user name in the upper part of the 'Permissions' window, then click 'Apply' at the bottom of the 'Permissions' window, and exit.

 

Once 'Permissions' are allowed, click the "Edit" tab at the top-left of the Notepad app window, and then find and click either "Find..." or "Find Next" in the drop-down window.

 

I just entered "stereo" in the 'Find' box, and then clicked 'next.' It took me right to these three lines:

 

;HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01
;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0
;HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00
 
Remove the 'semi-colons' from the front of each line, so they now look like this:
 
HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01
HKR,%EPattributePath%\EpSettings\StereoMixEnable,MixAssocSeq,1,E0,E0
HKR,%EPattributePath%\EpSettings\StereoMixEnable,MuteGainSettings,1,00,00
 
If you successfully changed the 'Permissions', you should then be able to 'save' the editing you have done, and close the Notepad app.
 
Then (I didn't do this, but...) you should probably reset the 'Permissions' settings back to their previous state, for the "CALCC2WA.inf" file.
 
If you have successfully accomplished all of this up to this point, the next step is to go to the 'Device Manager' in the Control Panel, and find your Conexant HD Audio device in there, and uninstall the drivers for it ... DO NOT select or check the box labelled "Delete the driver software for this device"  ... only 'uninstall.' If it is already 'checked' then 'UN-check' it.
 
Then restart your computer, and you should be able to find the "Stereo Mix" device in 'Control Panel \ Sound \ Recording tab' ... IF ... you have already right-clicked inside the box under the 'Recording' tab and checked "Show Disabled Devices" & "Show Disconnected Devices."
 
 
I hope this works for you as well as it did for myself.

 

Hi. New member here. I found this post by searching the internet and registered just to reply. I am keen to get this working on my Toshiba Win 10 Laptop but I can 't find the file called "CALCC2WA.inf". Can you or anyone offer any advice? I'm looking in C:\Windows\System32\DriverStore\FileRepository but can't find a folder called CALCC2WA.inf_amd64_07118bd8a2180658  I've also tried searching my PC for CALCC2WA.inf but no luck. Thanks for any help.



#3 MaxPC

MaxPC

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:59 AM

Posted 11 May 2018 - 07:10 PM

I had to do this for two different Toshiba model laptops and it worked great.

 

A couple notes to add here that might help others:

1. To find the right ".inf" file to edit (mine was different from the above) you can use an advanced text editor to search the "C:\Windows\System32\DriverStore\FileRepository" for ";HKR,%EPattributePath%\EpSettings\StereoMixEnable,Enable,1,01" or any of the other lines that you need to edit. I used a free one called PSPad (https://www.pspad.com/en/download.php) but there are others that can probably do the job.

 

To do this find the function that does search and replace text in files in a particular location. Enter the line of text, choose the directory to search in (be sure to include subdirectories) and then click search. (DO NOT enter any replace text or you could mess up your PC. You only want to locate the .inf file here). It might take a few minutes to locate the file. Make a note of the file name and locate the folder.

 

There may be other ways to find the correct file but this was easy for me.

 

2. File Permissions. On my system, I could not simply edit the permissions to allow access to write to the file. So I had to change ownership of the file from "System" and then edit the permissions for full control. To change ownership click "Advanced" in the Security tab for File Properties. Click "Change" next to the Owner: label. In the pop-up screen, enter your user account or you can select from the "Advanced" button. Once this is done, you can go back to the main dialog to edit Permissions and select Full Control. (More details here if you need: https://winaero.com/blog/how-to-take-ownership-and-get-full-access-to-files-and-folders-in-windows-10/). Remember to change permissions and ownership back once you have edited and saved the .inf file.

 

I'm not that familiar with Ownership/Permissions. I originally made a copy of the file in another folder to edit and copy back to the original folder. But was unable to rename the original file and copy the edited file back. The only way I could edit the file was in the original folder itself. 

 

WARNING: To be safe, make a copy of the original .inf file in another folder, so you have a backup in case something gets messed up with the editing process.

 

3. As noted elsewhere, there are possibly several instances of those lines in the .inf file. Be sure to edit all of them or the fix may not work as needed. The Find & Replace function in your editor works best for this.


Edited by MaxPC, 11 May 2018 - 07:11 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users