Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

usb wireless adapter not working


  • Please log in to reply
1 reply to this topic

#1 katochsajal0618

katochsajal0618

  • Members
  • 4 posts
  • OFFLINE
  •  

Posted 16 October 2016 - 12:21 PM


I have a ra-link usb wireless adapter. I bought it from online website. I have a pc with following specs:
Intel i7 6700 processor
Asus B150m plus (ddr4 version) m/b
Kingston hyper fury x ram 16 gb (8x2)
Zotac nvidea gtx 960 4gb gfx crd
Windows 10 pro 64 bit

...
So when i inserted that usb adapter in my pc it shows usb device not recognised with an exclamation mark.
In description it shows ..
The device cannot start. (Code 10)
The usb device returned an invalid serial number string descripor
Then i unplugged it from usb 2.0 and plugged it un usb 3.0 then it shows same error...
I have dual boot pc with ubuntu installed as secondary os.
So i booted into ubuntu and guess what. Usb adaptor was working fine.. recieving signals.. connection was fine. Internet was working.. then i tried it installing on my laptop. It was working fine in it too..
I guess it is a windows issue.. so i tried and installed windows 8.1 pro 64 bit. Same issue in that.. but works fine in ubuntu and kaali..


Edited by Chris Cosgrove, 19 October 2016 - 05:48 PM.
Moved from Network Streaming to External hardware


BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,227 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:07:14 PM

Posted 19 October 2016 - 05:55 PM

This sounds like a driver issue. I suggest you go to the Ra-link website and see if you can find the Win 8.1 drivers for this adapter.

 

I could understand that a completely different OS might include drivers that work with this device, but it is odd that it works in your laptop, although you do not say what OS is running on that. Win 10 is known for being unpredictable with wifi.

 

If you do find drivers it might be a good idea to disconnect the adapter before you install them.

 

Chris Cosgrove


I am going to be away on holiday until the 13th May. While I expect to have internet access my time on-line may well be limited and PMs may not be replied to as quickly as normal.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users