Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Dell Studio 1535 not powering on

  • Please log in to reply
No replies to this topic

#1 antoniu200


  • Members
  • 207 posts
  • Gender:Male
  • Local time:08:36 PM

Posted 14 October 2016 - 03:44 PM

Hi! I have been given a Dell Studio 1535 laptop to fix: the laptop isn't turning on. The person gave me the laptop and the charger, which was in a really bad shape. Tho I tried to power on the laptop. I was lucky, because, in a certain position, the charger would actually give current to the laptop and I managed to power it on. But, after 5 seconds, when I was in BIOS, the laptop stopped. I have moved the charger a mm. From that moment the laptop wouldn't turn on at all. I even tried with a new charger, but, besides that I worked in every position I insert it, it did nothing.

With the battery in, the laptop's charging light flashes 4 times red, and 1 time white.
Without the battery, the laptop's charging light goes on for 2 seconds, then turns off. The laptop can't be powered on in neither these situations.
What could it be? The power button? If yes, how could I power on that laptop with a PC power button?

EDIT: the new charger has 3.43A and the original one has 4.52A. Could that represent a problem?

Edited by antoniu200, 14 October 2016 - 04:30 PM.

BC AdBot (Login to Remove)



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users