Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disabling mouse wheel


  • Please log in to reply
6 replies to this topic

#1 madajs

madajs

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:39 AM

Posted 13 October 2016 - 06:13 AM

I want to disable my mouse wheel, I went into Intellipoint settings and unticked 'Enable vertical scrolling', I went into registry and set HKEY_CURRENT_USER\Control Panel\Desktop\WheelScrollLines to 0.

The wheel is disabled while using my browser and in notepad, but still works in wordpad and various other applications such as video games.

Does anyone have any insights to provide on why the settings I have adjusted are only working in some applications but not others? Are there any measures I can take that will provide total disable of the wheel?

Thanks for your time!

Edit: To be clear, I am looking to disable mouse wheel scrolling


Edited by madajs, 13 October 2016 - 08:47 AM.


BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:08:39 PM

Posted 13 October 2016 - 07:13 AM

You can configure mouse buttons in Control Panel.

 

Control Panel -> Devices and Printers -> Mouse

 

Works on 7... don't have XP to test on but should be similar.



#3 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:08:39 PM

Posted 13 October 2016 - 07:15 AM

or it might not work... there was a lot of new features come in with Win 7



#4 madajs

madajs
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:39 AM

Posted 13 October 2016 - 08:49 AM

You can configure mouse buttons in Control Panel.

 

Control Panel -> Devices and Printers -> Mouse

 

Works on 7... don't have XP to test on but should be similar.

Control panel -> Mouse opens my Intellipoint settings, wherein I did untick the 'Vertical Scrolling Enabled' option for my wheel. However it wasn't effective. I may have left things too vague in my OP, I'm specifically trying to disable the wheel scrolling.



#5 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:08:39 PM

Posted 13 October 2016 - 03:53 PM

Download Microsoft TweakUI from here.

  • Upload the file to here to check it's safety
  • Open the tool
  • Click the MOUSE field to expand its view
  • Click on WHEEL
  • Then uncheck the "USE MOUSE WHEEL FOR SCROLLING" box
  • Press Apply
  • Click OK.

Fixed?



#6 madajs

madajs
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:39 AM

Posted 13 October 2016 - 09:27 PM

I tried out your program, when I went to the indicated setting "Use mouse wheel for scrolling" was unticked by default (probably a result of my previous measures). I enabled the option, applied the setting, then disabled the option, and applied the setting, just to be thorough. As with my other methods, the mouse wheel continues to be disabled in some applications while still working in other applications.

I don't understand what the difference is between notepad and wordpad that creates a situation wherein the mouse wheel is correctly disabled in notepad but continues to function in wordpad. Perplexing!

 



#7 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:08:39 PM

Posted 13 October 2016 - 09:32 PM

Yeah, it's a weird one. I wish I could help more mate, but I don't even have a running XP machine anymore to test on...

 

I hosed the last one and installed Linux Mint on it. Unless you're running specialised software that can only run on XP I suggest you do the same thing.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users