Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

NAS login showing on all static IP addresses


  • Please log in to reply
6 replies to this topic

#1 Spidersbox

Spidersbox

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 05:21 PM

I have a block of 16 stitic IP addresses, with several servers on several IPs:

x.x.x.1 webserver

x.x.x.2 webserver (ssl)

x.x.x.3 linux server1

x.x.x.4 linux server2

x.x.x.10 nas

 

I setup a new NAS a couple of days ago with it's own static IP. It worked great until today.

I was checking up on some of the websites I host - and opps - the NAS admin login screen was there instead of the web site I was expecting.

 

I typed in the IP addresses of my other servers, and same thing. Matter of fact, I typed in IP addresses with nothing attached, and the login screen was there too!

 

 

I've had this happen before with a webcam/dvr system, and I fixed it by pulling the network cable out -

was hoping for a better solution with my NAS.

 

For now, I turned off the nas and rebooted my modem, and the other servers are serving correctly now.

 

What would cause my NAS to braodcast on every static IP in my block ??



BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 06:13 PM

Sounds more like a dns issue or a port forwarding issue.  How are you handling both?



#3 Spidersbox

Spidersbox
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 06:33 PM

port forwarding is turned off.

windows server on x.x.x.1 runs simplednsplus (I've used it since the late 1990's)

ubuntu server on x.x.x.3 runs bind.

 

there are no records pointing to the NAS



#4 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 08:41 PM

I am assuming you did your access via internal not externally.  Something internally was translating your request or something internal to your machine was doing the translating.  Either a program [install one with the NAS?] or perhaps your hosts file.



#5 Spidersbox

Spidersbox
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 09:04 PM

Nope. I was at work and was checking on a web site served by one of my servers at home.

everything works as it should at home, NAS, websites ect., (the NAS in question is installed at home, along with the servers in the first message)

 

But at work, when the NAS (at home) is powered on, all my static wan IPs show the admin login screen for the NAS.



#6 Spidersbox

Spidersbox
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 09:21 PM

Now, to make this more interesting, I changed the NAS back to DHCP, rebooted everything, and now if I type in my browser, or use the site.com name (at work)- I STILL get my NAS login screen.

I logged in and went to the network setup page and it reports:

IPv4 IP Address   192.168.0.22

 

Now I am at home, every thing works as it should, so I use teamviewer and remote to my computer at work, open a browser - go to one (or any) of my web sites (hosted at home) .. wait for it ..   ..  

NAS admin login screen.

:blink:



#7 Spidersbox

Spidersbox
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:20 AM

Posted 11 October 2016 - 09:31 PM

Damn, I think I found it. I was crawling around in my modem setting and found a list for UPnP NAT-T, and the NAS was listed.

I disabled UPnP - guess my NAS was trying to tunnel out.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users