Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo
- - - - -

How to get RedShiftGUI working correctly in 'Puppy' Tahrpup64...


  • Please log in to reply
No replies to this topic

#1 Mike_Walsh

Mike_Walsh

    Bleepin' 'Puppy' nut..!!


  • Members
  • 1,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:King's Lynn, UK
  • Local time:12:20 AM

Posted 06 October 2016 - 08:37 AM

Afternoon, all.
 
Back in the days when I ran XP full-time, I used to use f.Lux for night-time use. For those of you who don't know what this very useful app does, it basically turns your monitor to a warmer, reddish hue during the hours of darkness.
 
Why? I hear you say. As it happens, research has shown that the blue-white light emitted by computer monitors tends to adversely affect your sleep patterns. Reddish light, on the other hand, does not.....and your sleep should be as restful as usual.
 
Well, it works for me.....
 
When I moved to Puppy, I found that f.Lux, although available for Pup, was command-line only.....and a total PITA to set-up, at that. Searching around revealed the equivalent app called RedShiftGUI (which to my mind, in fact works better).
 
I originally used only 32-bit Pups, despite the fact that my old Compaq desktop has always been 64-bit capable. I discovered the .pet for RedShift, in stu90's thread, from here:-
 
 
However, the link for this one is now dead. Puppy forum member Pelo, however, alerted me to the fact that it was still available from the German repositories, further down in the same thread, and I have been using it regularly ever since, in all my 32-bitzers.
 
Recently, I've started using the two 64-bit 'flagship' Pups; Tahr64, and Slacko64. Even with 32-bit compatability libs, the 32-bit version won't work. RedShift was available through the PPM (Puppy Package Manager).....but it still wouldn't work. So I searched around for a 64-bit version, and found it at GitHub, here:-
 
 
The 64-bit .deb package installs into Tahr64 without a murmur. However, upon starting it for the first time in the terminal (I've got into the habit of always doing this with new apps, to see what problems might crop up), it returns the following error:-
 
root# /usr/bin/redshiftgui
Error: PM:[opt_parse_map] Map empty.
 
Hm, I thought. Odd. Anyway, I Googled the error, and found this, also at GitHub (evidently, the problem is obviously a long-standing one, given that this version of RedShift is now over 6 yrs old):-
 
 
The given 'fix' is to locate the hidden config file ~/.redshiftgrc in the user's home folder. Well, that's Ubuntu; in Puppy, the config file is located in /root. (To show it, use the 'eye' icon in the ROX menu bar). If you open the config file with Geany, you'll find the following:-
 
min
temps=6500:3600
latlon=52.779999:0.430000
speed=1
method=Auto
map=177.00|100.00;3.00|100.00;-6.00|0.00;-174.00|0.00;
 
The 'latlon' in line 3 is my personal geographical coordinates. 'Speed' can be anywhere from 1k/sec (very slow) to 1000k/sec (almost instantaneous). Yours will, of course, be different.....depending on your settings.
 
What you need to do is to replace each of the 'pipe' symbols ('|') in line 6 with a comma (','), so that it reads like this:-
 
min
temps=6500:3600
latlon=52.779999:0.430000
speed=1
method=Auto
map=177.00,100.00;3.00,100.00;-6.00,0.00;-174.00,0.00;
 
Save, and close Geany. Now, when you fire it up from the Utility menu, it will run. You'll see a red 'lightbulb' symbol appear in the tray. Left-click on it, and you'll get a window similar to this:-
 
 
OXdz7QZ.png
 
 
 
 
Right-clicking will return you to the daylight setting. To return to the night-time transition sequence, right-click on it again.
 
To set it up, simply follow the instructions I outlined for Puppy forum member step in my post on the subject:-
 
 
Sweet dreams, everybody!
 
 
Mike.  :wink:

Edited by Mike_Walsh, 06 October 2016 - 10:15 AM.

If the information given has helped you, please remember to say 'Thanks!'

My Puppy BLOG ~~~  My Puppy PACKAGES

Compaq Presario desktop; Athlon64 X2 3800+, 3 GB RAM, WD 500GB Caviar 'Blue', 32GB Kingspec PATA SSD, Seagate 'Expansion' 1 TB  USB 3.0 drive, ATI Radeon Xpress 200 graphics, Dell 15.1" pNp monitor (1024 x 768), TP-Link PCI-e USB 3.0 card, Belkin PCI USB 2.0 4-port card, self-powered 7-port USB 2.0 hub

Dell Inspiron 1100; 2.6 GHz P4, 1.5 GB DDR1, 64GB KingSpec IDE SSD, Intel 'Extreme' graphics, 2 x 128GB SanDisk Cruzer 'Fit' USB 'external' storage.

 

XQxSFqE.gif

 

 


BC AdBot (Login to Remove)

 


m



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users