Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Frameskipping problems.


  • Please log in to reply
10 replies to this topic

#1 FrozdY

FrozdY

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 05 October 2016 - 11:54 PM

Hello everyone, I as the title states have a problem with frameskipping, it's the best way to describe my problem really, for example, WoW shows me that I have 60 FPS, but when you look at it with your eyes, it's not 60 FPS, it's more like 10, it's not as smooth as 60 should be so to speak.

 

Games this occurs in:

WoW

Skyrim

Grid 2

Assassin's Creed Syndicate

Max Payne 3

Sleeping Dogs
Rust
Modded Minecraft

 

Games where this doesn't occur:

Trackmania 2 stadium

CS GO

Garry's Mod

Dirt 3

Vanilla Minecraft

Boarderlands(all)

ARK: Survival Evolved(not that often that it would become a problem)

 

So I was wondering what you guys think is wrong, I believe that it's my rig and how the components works together, and let's just say that the synergy between them is, well... poor.

In any case, I can't stream, and that's something I'd like to be able to do, so I was thinking if you guys could tell me what I could upgrade/swap to based on my setup that I already have, like maybe a new motherboard or something, I'm not made of money so if you can see 1 thing I can change to something else, that would be greatly appreciated.

 

So here's my components:

OCZ Vertex 3 Series SSD SATA-600 550mb/s read and 525mb/s write

AMD Black Edition FX 6200 / 3.8GHz Hexa core processor

CORSAIR AX 1200W PROFESSIONAL SERIES MODULAR PSU
GIGABYTE GA-970A-UD3 AM3+ ATX the white and blue one

4x KINGSTON 8GB 1600MHZ DDR3 CL10 DIMM HYPERX BLU

MSI R9 390 8G

AOC 24" LED G2460PQU / 1ms / 144hz through DisplayPort

 

And these by them selves shouldn't be this bad to be honest, and the graphics card should be able to handle all of those games in high quality atleast just by it self in 60 FPS, so do you guys have any ideas preferably any tools that could optimize my PC somehow, I would appreciate that so much, thanks.


Edited by hamluis, 06 October 2016 - 10:14 AM.
Moved from System Building to Internal Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 Zone_86

Zone_86

  • Members
  • 303 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:07 PM

Posted 08 October 2016 - 03:57 AM

When did you firrst notice this happening?


Edited by Zone_86, 08 October 2016 - 04:46 AM.


#3 Arniix

Arniix

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:07 PM

Posted 08 October 2016 - 06:02 AM

it might be your nvidia drivers uninstall & re install them to try (i have the same problem but only with csgo) 

it was my hdd 

& which window you run on



#4 FrozdY

FrozdY
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 09 October 2016 - 03:30 PM

Zone:

like a week after I swaped to the MSI R9 390.

Arniix: 

It's Radeon, not Nvidia, and that was the very first thing I did, but thanks for wanting to help me :D I use Win 7 64 Ulti


Edited by FrozdY, 09 October 2016 - 03:31 PM.


#5 King_Yoshi

King_Yoshi

  • Malware Study Hall Senior
  • 1,349 posts
  • OFFLINE
  •  
  • Local time:04:07 PM

Posted 10 October 2016 - 02:55 PM

After spending a bit of time looking up this problem, this may fix your problem.
(I found numerous other posts with this same problem. This seems to have fixed it.)

 

Go to either Crimson or the Catalyst Control Center. (Whichever you are using.)
Find the "Anti Aliasing Method" setting and set it to "Adaptive".

Also, check out your video card's temperatures as well as how much of your CPU is being used while running the games you are experiencing frame skipping in.

 



#6 FrozdY

FrozdY
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 11 October 2016 - 12:38 PM

King_Yoshi: I didn't have any adaptive stuff, I have it in swedish and it's really confusing when it is in swedish, but I chose everything I could with like "adaptive" and we'll see.

My video card never exceeds 35C(95F) that's the highest it's been ever and that was in the hottest of summer days here, my processor was at that temp. aswell at that time, and I'm at highest at 75% on CPU usage, it's usually between 60% and 75%, so I don't know, I had no probs what so ever when i first installed the graphics card, nor dud I have any probs when I updated the drivers, it just suddenly happened for some reason...



#7 King_Yoshi

King_Yoshi

  • Malware Study Hall Senior
  • 1,349 posts
  • OFFLINE
  •  
  • Local time:04:07 PM

Posted 11 October 2016 - 01:55 PM

Your temperatures seem fine and 75% of CPU usage shouldn't be a problem either.

 

Also, according to the interglot dictionary "anti-aliasing"  = "kantutjämning" in Swedish. (I hope its a correct translation.)

 

It should only be 1 setting.

Don't change too many settings at once, since others may cause new problems or cancel out the fix.

I know its a pain, but changing 1 setting, then testing, then changing it back if that setting didn't help is the best way to work on these problems.



#8 Zone_86

Zone_86

  • Members
  • 303 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:07 PM

Posted 15 October 2016 - 02:21 AM

Hmm how old is this power supply? I have installed and ran that one myself when a ran 2x HD 7970's long ago. The reason I ask is that you noted that this issues started soon after the upgrade to the R9 390. Now, if you are monitoring your +12v rails through both the BIOS and also HwMonitor and they seem nominal, then your next course of action  (what I would do) is uninstall your AMD drivers, and then after that reboot into safe mode (this is not how others do it it's how I do it) and run DDU to get the NV remnants off of your system and our of the windows registry hooks. Once done boot into *win* and reinstall your AMD drivers.

 

http://www.guru3d.com/files-details/display-driver-uninstaller-download.html



#9 FrozdY

FrozdY
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 24 October 2016 - 01:14 AM

I'm sorry for the delayed answer. I lost this post for some reason and I looked and looked all over for it, and now I thought: "Why not google it?..."

 

Yoshi:
Yeah, I've been running that setting now since I last replied, so I had it setup the way it was supposed to, but no change, less fluctuation in the FPS, but still bad :(

Zone:
It's from 2013, so not that old to be honest, and all my components have recently been cleaned aswell so, I don't get it...



#10 FrozdY

FrozdY
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 25 October 2016 - 03:19 AM

Okay, I've figured out what's causing it, not how to fix it, except by getting a new processor unfortunately, the graphics gets bottlenecked by the processor, I didn't think that it got necked since the system didn't show any severe %ages on the CPU usage, however, running a program like CineBench, wasn't really nice seeing the perfomance points of 337CB/1279... anyway, my system don't recognize hard load in games, but it showed signifigant load in the CineBench, and the OpenGL was 65,51 FPS/67,71, so it's not the graphics fault since it's the 2nd best according to CineBench, and my processor is the 2nd worst...



#11 FrozdY

FrozdY
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:09:07 PM

Posted 25 October 2016 - 05:06 AM

Okay, one thing that seems to have helped signifigantly is: http://www.coderbag.com/programming-c/disable-cpu-core-parking-utility that enables all your cores so that all cores are active at all times instead of some of the activating and deactivating all the time.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users