Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External drives keep going inaccessable


  • Please log in to reply
2 replies to this topic

#1 tzoromski135

tzoromski135

  • Members
  • 58 posts
  • OFFLINE
  •  
  • Local time:04:02 AM

Posted 04 October 2016 - 09:03 PM

I seem to have the worst luck with external Hard drives lately - I had a Seagate Backup Plus 8TB drive fail within 4 months of buying it when windows 10 did a "scan and fix" on it claiming there were errors with the drive.  Thank goodness I had warranty on it - or so I thought - Seagate didn't send me a NEW drive - they sent me a "Re-Certified" drive that Windows 10 saw at first and I was able to access, then I formatted it to erase the software they preloaded on it for back up.  After the reformat, the drive went invisible under "This PC".  I was able to see it on Disk Management and found that the drive had 3 partitions on it - I merged the partitions and was able to assign the drive a letter which made it visible under "This PC".  I thought that fixed it...until MICROSOFT forced the Anniversary Update 1607 on me which once again made the drive vanish and lose its letter label.  I assigned it a letter and that fixed the issue.  Why did an update make my PC not recognize the external drive and automatically assign it a letter when I plugged it in?

 

This past weekend, I had an incident with my other Seagate 3TB external drive - it got knocked off a table which caused the base to fracture and thought the drive inside was toast and that I lost all the music and videos on my drive - I hadn't been able to back it up onto my new drive since the anniversary update screwed things up again.  I took apart the external enclosure, saw the drive seemed unscathed inside, bought a new enclosure and installed the drive inside it, powered it on and listened to the drive - no noises and it was spinning. I connected the external drive to my PC and the PC wanted to format the drive.  I ran testdisk on the drive - it saw the partition, however I got an error saying "partition unrecoverable - drive is too small".  Of course, Googling the issue showed that I should just direct install the drive in my PC, which I did, however now the PC was telling me "drive cannot be accessed, parameters are incorrect"  Under Disk Management, it showed my partition on the drive had gone "RAW".  I ran TestDisk again and thank god, the program found the partition again and listed all my music and videos, so now I'm copying the bad drive to my new drive which is being a very slow procedure.

 

I've ordered another brand new Seagate 8TB external drive from Amazon which I will create another backup once this copy procedure is complete.  I plan on re-formatting the bad drive once done with the copy procedure to make it usable again, because it passed all tests.

 

I do have questions though - why do updates make my PC not automatically assign the drive a letter so I can access what's on them?  How do I prevent my drives from becoming inaccessible?  My PC is once again waiting with another update to the anniversary update that it will apply automatically once it sees that my PC is no longer being used or shuts down.  I'm kind of afraid that my data I'm backing up onto the re-certified drive will become lost next time I plug in the USB after this update is installed as the PC no longer assigns letters to the drives that are plugged in the USB port. I'm not sure if I'm doing something wrong here with formatting the drives, or if this is a common issue now that Windows 10 has been forced upon us.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,582 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:02 AM

Posted 07 October 2016 - 01:13 PM

There have been a lot of complaints regarding the Anniversary edition but it mostly concerns drives that became repartitioned or RAW. You were fortunate enough where all it did was remove the drive letter. Never have an external drive attached during a Windo ws 10 major update. There have been issues where Windows 10 added a letter to the EFI partition than normally does not have one. I wonder what surprises are in store for the next two major updates in 2017. I recommend you always have an updated disk image backed up to an external drive using program such as Macrium Free or Aomei Backupper especially before a major Windows 10 update.

 

See the comment by rusself 12 days ago on this thread.

 

http://betanews.com/2016/08/08/big-problems-windows-10-anniversary-update/

 

-doesn't recognize my 500GB external hdd which has 2 partitions on it and is where most of my data is. recovered most with recovery software, but process stopped b/c windows kept changing how it recognized the drive: both partitions RAW, then showed one partition which became accessible, one as RAW, then completely gone, then would suddenly see drive again and i'd get notification that it needed formatting (though running chkdsk should they were still NTFS and lazesoft recovery suite can access the files) I am about to go ahead and reformat it and lose what i didn't recover (which thankfully isn't much overall)

 

 

Also this thread. Read the comments.

 

https://www.reddit.com/r/sysadmin/comments/4vycur/windows_10_anniversary_update_deleted_a_whole/


Edited by JohnC_21, 07 October 2016 - 01:16 PM.


#3 kabous

kabous

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 29 November 2016 - 11:14 AM

 my 1 t hard drive want work it said error 10  i can hear the pc pick it up but it dont show






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users