Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Register at Notepad++ new forum?


  • Please log in to reply
No replies to this topic

#1 uberbleeper

uberbleeper

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:02:43 AM

Posted 01 October 2016 - 09:33 PM

Has anyone registered at the "new" Notepad++ forum:  https://notepad-plus-plus.org/community/login

They've been there a while (were at Sourceforge).

 

I see no option to register there.  Tried 2 browsers & looked that the page source.

Didn't find anything on "register" or "registration."  Unless the site is temporarily broken.  I can browser / search it, though.

 

Trying to find out why can't get the Windows (Vista) x64 shell context to work, for Notepad++ 7.0 PORTABLE.

I downloaded the 32 bit NPP.bin.7z  (I've always used the 32 bit on my 64 bit Vista).

 

Don mentions you can add in explorer context menu for the portable NPP version here:  http://docs.notepad-plus-plus.org/index.php/Explorer_Context_Menu

 

He has a link to what appears an old version of nppshell.dll, that he says you'll need:  http://notepad-plus.sourceforge.net/commun/misc/NppShell.New.zip

But, the 32 bit dll from that download link is several yrs older than the nppshell.dll file from NPP v6.7.3.  So maybe the shell dll from his link is just too old?

 

Followed his instructions - placing nppshell.dll in the root program folder.  Then register it w/ Regsvr32 (he only mentioned doing it in Win 7).

Went ahead & ran Regsvr32 from elevated cmd prompt & got the  menu that allows setting up the context menu entry.

Seemed to work -  no errors. It created reg entries for Notepad++ shellex.  Rebooted.  Still doesn't show up in context.

 

After running Regsvr32, a registry search finds dozens of entries for the new NPP v7.0 portable - associated w/ it's ID:  {00F3C2EC-A6EE-11DE-A03A-EF8F55D89593}.  

Like -

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{00F3C2EC-A6EE-11DE-A03A-EF8F55D89593}\Settings

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{00F3C2EC-A6EE-11DE-A03A-EF8F55D89593}\Settings

 

Maybe I should un-register that old shell dll & remove it, get a newer copy of  it from the installer package, then register that?



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users