Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Extremely low ethernet speed on Gigabit-capable network cards


  • Please log in to reply
5 replies to this topic

#1 Hashim1

Hashim1

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:07:47 PM

Posted 29 September 2016 - 08:10 PM

I recently bought a Belkin 2m cat5e crossover cable to connect my desktop to my D530 laptop, in the hopes that it would be a faster way for me to directly transfer data between the two. The desktop's ethernet card is a Realtek PCIe FE Family Controller (model no. RTL8167), and the D530's is a Broadcom NetExtreme 57xx Gigabit Controller (model no. B57ND60X). Both seem to be gigabit-capable cards, yet I'm not able to get gigabit speeds from them; when looking at the connection, it shows 100Mbit/s, and the fastest speed that each of them can be set to in Device Manager -> Advanced -> Speed & Duplex is 100Mbit Full Duplex. Even worse, I'm not even getting those speeds when I transfer data - I'm getting a measly 1MB/s, so about 8Mbit/s, and even that is constantly dropping.

So far, I've tried updating uninstalling and then updating both drivers automatically via the Device Manager.

I then manually installed drivers, the Desktop's from here: Realtek RTL81XX PCI-E Network Connection Driver Driver Details | Dell UK, and the laptop's using DriverMax because I couldn't find a driver for it.

Still no luck, and I'm now at a loss for what to try. When I bought the crossover, I really didn't think it'd take this much to get it up and running, I suppose I was under the naive impression it'd be pretty much plug-and-play.



BC AdBot (Login to Remove)

 


#2 gigawert

gigawert

  • Members
  • 1,304 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:47 AM

Posted 29 September 2016 - 08:32 PM

It may be a hard drive read/write speed limitation, but I'm not completely sure.


John 3:16

 "God loved the world so much that He gave His uniquely-sired Son, with the result that anyone who believes in Him would never perish but have eternal life."


#3 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 29 September 2016 - 08:40 PM

In the configuration settings of both cards go to the advanced tab and select 'speed and duplex' then select on both '100mb full duplex'.
This will make them talk the same to each other no matter what [assuming the cable is good]

 

Test your access again.

 

If successful go to 1000mb and see what happens


Edited by Wand3r3r, 29 September 2016 - 08:52 PM.


#4 Hashim1

Hashim1
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:07:47 PM

Posted 30 September 2016 - 06:51 PM

In the configuration settings of both cards go to the advanced tab and select 'speed and duplex' then select on both '100mb full duplex'.
This will make them talk the same to each other no matter what [assuming the cable is good]

 

Test your access again.

 

If successful go to 1000mb and see what happens

 

This is what I explained in the initial post - when I went to this menu, there was simply no option on either card for 1000Mbit - the highest was 100Mbit Full. However, setting both cards manually to 100Mbit Full Duplex has now solved the smaller problem of getting just 1MB/s transfers - I'm now getting a healthy average of 11MB/s. Thanks for that. I suppose, for some reason, the network cards weren't auto-negotiating the speeds? Or maybe that's down to the network cable. Anyway, now all that's left is the primary dilemma of why there's no option in the same menu to select Gigabit speeds, even though I have Gigabit-capable cards.


Edited by Hashim1, 01 October 2016 - 02:03 PM.


#5 Hashim1

Hashim1
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:07:47 PM

Posted 01 October 2016 - 02:02 PM

Anyone at all?



#6 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:11:47 AM

Posted 03 October 2016 - 12:09 AM

Then you must not have the right drivers if you don't have gig choices.  Review the drivers






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users