Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


WD My Book External Drive Not working

  • Please log in to reply
5 replies to this topic

#1 adamjedgar


  • Members
  • 25 posts
  • Local time:01:30 PM

Posted 26 September 2016 - 05:44 PM

HI guys,

I have Western Digital External HDD (2 TB - Green) that seems to have stopped working. 


It was working perfectly before i went to bed, but not the next morning. I know that windows 10 did install updates in the last few days, however, i am not sure if this caused the problem or not. My dropbox subscription also downgraded from business to standard as well, and dropbox was linked to this drive.


In windows the WD external HDD no longer shows up in explorer, however, it is visible in virtual disk manager 


Windows VDM says that the disk isnt initialised, but when i attempt to initialise the disk is says cannot be initialised due to a "fatal hardware error".


I have checked the drive and the heads are not stuck. I can hear the disk spin up and the usual initial clicking noise that mechanical drives make when first powered up. I have also visually checked to make sure heads are not stuck on the platters and all is ok. The top platter doesnt appear to have any surface damage that i can see and heads seem to move ok.


I have removed the external drive from its case, separated the UBS connector circuit board from the drive and manually installed it directly to 2 different computer motherboards, as well as connecting it via USB to laptop...all with same results (ie cannot initialise the disk due to a fatal hardware error)


I have tried accessing the disk from the cmd line and it isnt listed


disk is generally visible from the bios, although this seems to be a bit hit and miss at times.


the drive is less than a year old (limited warranty runs out in late 2017)...although now i have had the disk apart the warranty is obviously voided. I am not interested in the warranty anyway, the data is most important (not the $170 drive)


Limited warranty doesnt cover data loss and i have been quoted between $600 and $1500 AUD to recover the data on the drive by a WD approved data recovery specialist here in sydney Australia. 


So...here goes the question


My priority is the data, but i dont really have the money to send it to a specialist.


I am thinking of simply purchasing another identical drive (considering this one is obviously stuffed and needs replacing anyway), ensuring that the purchased replacement has same firmware as the one that is stuffed (WD ver 1050), and swapping the two platters from my bad drive into the new one, and attempting to copy the data from it.


seen quite a few youtube videos and this seems like a very good option. 


has anyone else successfully done this?



BC AdBot (Login to Remove)



#2 TsVk!


    penguin farmer

  • Members
  • 6,230 posts
  • Gender:Male
  • Location:The Antipodes
  • Local time:11:30 AM

Posted 26 September 2016 - 06:02 PM

Physically repairing disks is relatively difficult as the operation needs to be done in a "clean room". There is a good chance that you have already damaged the disk platters just by opening it up in a normal environment.


Not saying that what you're proposing is impossible. Feel free to have a go... but rather than being disappointed that it doesn't work you should be delighted if it does, as you would expect it not to generally.


Good luck.

#3 RolandJS


  • Members
  • 4,448 posts
  • Gender:Male
  • Location:Austin TX metro area
  • Local time:08:30 PM

Posted 26 September 2016 - 06:50 PM

Is this one of the WD HDs with onboard/circuit-level encryption?  And, something similar to Smartware[?] and/or Drive Unlock?

"Take care of thy backups and thy restores shall take care of thee."  -- Ben Franklin revisited.


Backup, backup, backup! -- Lady Fitzgerald (w7forums)

Clone or Image often! Backup... -- RockE (WSL)

"I heard Spock finally got colander!"  "I believe the word is Kolinahr."  "Oh."

#4 adamjedgar

  • Topic Starter

  • Members
  • 25 posts
  • Local time:01:30 PM

Posted 27 September 2016 - 12:26 AM

Hi guys,


I am not sure what type of encryption the drive uses.

My understanding is that it does use Smartware.

Not sure about Drive Unlock.


Drive details are as follows;


WD 2.0 TB SATA / 64 MB Cache WD20EZRX

Date: 12 March 2014 (I purchased it new last year)


DCX: 2W0012621

5VDC: 0.60 A

12VDC: 0.45A

R/N: 771945


My understanding, from a computer mate, is that the green model WD drives (which this one is) are terrible. In fact he doesnt like Westernd Digital drives full stop.



A side note...my wife had another WD external drive that crapped itself about 5 years ago after only a short period of use ( 320GB WD Scorpio Blue. Built in Nov 2009). That drive experienced a failure and i left it in cupboard all this time thinking it was a useless prospect as it had no power. I couldnt believe my eyes when i simply pulled the drive out of its cover, removed the USB SATA board and connected directly to motherboard SATA Ports instead. Bloody thing powered up perfectly... I made my wife's day yesterday as I recovered all the data off that one  (it had a lot of our kids baby photos on it)

#5 JohnC_21


  • Members
  • 22,137 posts
  • Gender:Male
  • Local time:09:30 PM

Posted 27 September 2016 - 09:59 AM

A failed WD MyBook is not good. WD uses a proprietary USB Bridge/PCB card on the drive. See the following links. Personally I avoid these drives like the plague. It's better to purchase a good bare drive and your own enclosure.










There is a youtube video where the uploader purchased an identical enclosure and swapped drives to pull the data but I think you may have problems since you have already opened the drive to the environment.

#6 adamjedgar

  • Topic Starter

  • Members
  • 25 posts
  • Local time:01:30 PM

Posted 27 September 2016 - 06:45 PM

G'day JohnC_21,

you have reflected my thoughts almost exactly.

Once i pulled the drive apart to check that the platters and indeed the heads were not stuck (even though from an audible perspective they obviously were not), I began thinking i should have simply started out doing exactly what this video suggests...replace the control board first with that of a new identical drive.


Having said that...I have bypassed the control board all together and still have the initialisation issue. So i am wondering if the control board is actually the issue? I am thinking that perhaps my problem is a little deeper than that but time will tell.

I have watched the video, and will attempt to perform the exact same operation to see what eventuates.


Thanks for you help...i will report back once i have completed this task.


kind regards



ps, here is what a WD rep had to say on their own forum about my issue


Hey there, @Adam!

I'm really sorry to hear about your WD My Book failure! frown.gif  You have done a great job with the troubleshooting so far, but I'd definitely not advise you to take the HDD out of the enclosure as it voids the warranty status of the product and mostly because the WD My Book incorporates a hardware-based encryption that prevents you from accessing your files without the original external enclosure. If you suspect that the issue could be caused by the enclosure, you could definitely try buying an identical one and check if you will be able to access your files then. However, tampering with the HDD physically is highly dangerous and could further corrupt the contents on the drive.
You mentioned that the SMART status was not available when you tried running the QUICK and EXTENDED tests, however, I'd still recommend you check if you will be able to run the tests successfully from another computer. Either way, capacity 0 mb is pretty concerning as it could actually mean that the HDD is damaged beyond repair.

Edited by adamjedgar, 27 September 2016 - 06:49 PM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users