Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Gaming Headset Problems - Please help! :(

  • Please log in to reply
1 reply to this topic

#1 Pipples


  • Members
  • 1 posts
  • Local time:05:34 AM

Posted 22 September 2016 - 06:29 PM



I got a Philips SHG7980 Advanced Gaming Headset last month. It is connected via a USB. It worked perfectly until today. This afternoon I plugged in a USB keyboard and ever since, my headset is no longer working on my computer. I am running Windows 10.

I tried plugging my old keyboard back in. No luck. I have also tried uninstalling and reinstalling the drivers for the headset. The headset is being recognised as USB AUDIO DEVICE instead of PHILIPS SGH7980 which is what my computer used to recognise it as. I can't hear any audio whatsoever and my microphone is showing that audio is going in but I just can't hear it even if I plug my speakers in (they work for other audio.)


Any ideas? I've had my partner and a friend try and help me with this but I still can't get it to work. It's not the headset that is the issue as I borrowed my partner's headset (different brand) and it worked for 20 minutes and then stopped. Was still being recognised but no sound was coming through and the mic wasn't picking anything up.


Any advice is welcome. :)





BC AdBot (Login to Remove)



#2 Trikein


  • Members
  • 1,321 posts
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:11:34 PM

Posted 23 September 2016 - 06:24 AM

Have you tried resetting the headphones? Couldn't find documentation but possible holding down power and volume + button. Also, what driver are you using? I couldn't find any on their website and their forums say it doesn't support anything past Windows 7.


Also, have you tried a different USB port? Like a back/side/front port? Maybe it got damaged when disconnect/reconnecting the USB port. 

Edited by Trikein, 23 September 2016 - 06:26 AM.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users