Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

samba share setup


  • Please log in to reply
3 replies to this topic

#1 NomoWindows

NomoWindows

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 20 September 2016 - 02:11 PM

# I need some help with a samba share setup. I followed the instructions I found here:

# http://tutorialforlinux.com/2016/02/15/easy-file-sharing-with-smb-quickstart-on-ubuntu-16-04-# xenial-lts-linux/

# From the client computer, I’m able to see files in the sharing folder on the server. But I can’t add or delete files. I would like to be able to read, write and create new files from the client side. I would also # like to launch mp3 and other media files from the client.

 

# Here is what I did on the samba server computer.

 

cd /etc/myUser/samba

 

service nmbd stop

 

service smbd stop

 

sudo cp smb.conf smb.conf.orig

 

sudo gedit /etc/samba/smb.conf

 

# Then I added this to the smb.conf file:

 

[sharing]

   comment = Sharing Directory

   path = /home/myUser/sharing

   browseable = yes

   read only = no

   guest ok = yes

 

# Set file permissions and restart

 

chmod +r /home/myUser/sharing/

 

chmod -R +r /home/myUser/sharing/*

 

service nmbd restart

 

service smbd restart

 

 

# On the client computer

 

smb://198.168.0.2/sharing/



BC AdBot (Login to Remove)

 


#2 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:14 AM

Posted 20 September 2016 - 02:23 PM

For whatever reason, I was never able to do anything with the share (write and edit) until I just set the permissions to full access (777). Inside your internal network it shouldn't' be a big deal (samba isn't accessible from outside unless you open the port on the router anyway). Try setting the folder/file permissions to 777 and see if that works for you. I don't see anything wrong in your smb.conf file.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#3 NomoWindows

NomoWindows
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 21 September 2016 - 12:48 AM

Thanks for the advice for using chmod 777.  I thought I would check this out one more time before I used 777.  I found a site called http://chmod-calculator.com/ Then I checked the permissions of my /home/myUser directory with ls -l The permissions for my Documents folder is drwxrwxrwx. I pasted this into http://chmod-calculator.com/ and came up with 777. I changed the permission of /home/myUser/sharing to 777. The Samba share works great now.


Edited by NomoWindows, 21 September 2016 - 12:51 AM.


#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:14 AM

Posted 21 September 2016 - 08:50 AM

Awesome, glad it is now working!

 

Yup, anytime you see "drwxrwxrwx" it is 777. Its broken into three categories, user, group, world. Each has a max permission setting of "rwx" which is read, write and execute. If all three are set, they add to 7, so 777 is full permission to each of those three categories. 


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users