Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Crashing issues with various apps (all made with QT, as far as I can tell).


  • Please log in to reply
No replies to this topic

#1 darkaegis

darkaegis

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:51 AM

Posted 14 September 2016 - 03:06 PM

Sorry ahead of time if this is the improper forum for this - I couldn't see any others here that would fit the issue.

First off, basic information:

I'm running Windows 10 64 bit on a 256gig SSD with 16 gigs of ram, a GTX 970, and an i5 3570k, very gently overclocked (although I've reverted it to "normal" in my efforts to fix this issue).

This issue has persisted through two reinstalls of Windows 10 and it's absolutely infuriating.

Basically, a few different programs are crashing and throwing out errors in my Windows Event Logs with the faulting module as something related with qt5. It's different between apps, I believe, but they're generally preceded by qt5. Off the top of my head, one is QT5core.dll, I'll have to check again for the others, if it is important.

Before my first reinstall, I ran just about every virus scan known to man alongside three different rootkit detectors with, predictably, no results.

The apps that it has affected so far - EAC (EasyAntiCheat) - I'm completely unable to start EasyAntiCheat, so any game that uses it is out of the question. This includes Hurtworld, Rust, among others.

The HTC Vive installer crashes before it starts. Also pointing to a QT5core.dll fault.

ReVive, an overlay to add Oculus games to Steam VR, crashes before starting and fails to do what it needs to do. This one points to a different QT5 dll, but I can't remember it off of the top of my head.

Edit: Add Stellarium to the list. I'm fairly certain this is related to QT, since that was also built in QT. I'll try a few more apps.

It crashed with this error.

The same (or similar) to the others.

Steam VR, which is also built on QT, works, but the menu is buggy and often seems to display corrupted text instead of the actual menu items (for example, "options" would turn into "Menu_Vive_Options" or something similar).

Edit 2: Add another app to the list. Origin is crashing with the same error (even though it has worked in the past). When it doesn't crash outright, It's giving me this screen when I log in.

I'm generally pretty tech savvy, but I've got absolutely no idea where to start here because it seems like I'm the only person on the internet having these issues. I tried reinstalling all Windows C++ libraries to no avail, but I don't know enough about the qt* dll files to figure out what else I might need.

What I've done so far:

  • Complete Windows format and reinstall (twice) as well as an in-place refresh (once).
  • RAM Test (Memtest overnight)
  • Prime95 CPU test (seven or so hours)
  • Revert from safe, stable overclock to stock (You know, just in case)
  • Multiple, exhaustive, virus scans, including Malwarebytes and a number of rootkit scans. Nothing at all. Of note, I haven't had a virus for over a decade, so this was just me being paranoid.
  • Uninstalled, repaired, and installed a whole slew of runtimes
  • Ran a chkdsk followed by an SFC scannow, followed by a DISM. No issues detected or repaired.
  • Per-app troubleshooting and compatibility tests
  • Changing the hard drive they're installed on. I've got a number of hard drives - I keep my gaming stuff separate from my OS. I doubt that would matter, considering a lot of people do this, but I was desperate.
  • Selective "clean boot" with no non-windows services or startup apps running.

Related, I dug this up via the error code I was getting - could it be related, or is this just related to developing? https://blog.inventic.eu/2014/08/qt5-application-crashed-with-error-0xc0000005/

 

Thanks ahead for literally anything anyone can muster. I'm getting desperate here.


Edited by darkaegis, 14 September 2016 - 04:00 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users