Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

spoolsv.exe missing


  • Please log in to reply
20 replies to this topic

#1 jmhoffer

jmhoffer

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 September 2016 - 09:21 AM

I tried to print something and the computer straight up no longer recognizes printers. In searing for fixes, I discovered that somehow, spoolsv.exe is gone. My installer contains no options for repair, which is the only solution I found online. Can anyone direct me to a download or send me one? Otherwise I'm kind of screwed.



BC AdBot (Login to Remove)

 


#2 Daydreamed

Daydreamed

  • Members
  • 349 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Dimension C-137
  • Local time:04:37 AM

Posted 12 September 2016 - 10:25 AM

Hello,

 

I am a bit confused as what you mean by installer. Do you mean your Windows installation media, or your printer installation media?


- Daydreamed


#3 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 September 2016 - 10:26 AM

Windows installation media. No repair option, which is what everything online says to do.



#4 Daydreamed

Daydreamed

  • Members
  • 349 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Dimension C-137
  • Local time:04:37 AM

Posted 12 September 2016 - 10:48 AM

Hello,

 

Let's try this....

 

If you are confused about a step, don't hesitate to ask! :)


- Daydreamed


#5 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 September 2016 - 10:54 AM

Did that already. Didn't work.



#6 Daydreamed

Daydreamed

  • Members
  • 349 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Dimension C-137
  • Local time:04:37 AM

Posted 12 September 2016 - 11:06 AM

Do you have your installation media to your printer?


- Daydreamed


#7 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 September 2016 - 11:07 AM

Plug and play.



#8 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 September 2016 - 11:08 AM

I found the driver and I'll try installing it, we'll see what happens.



#9 Daydreamed

Daydreamed

  • Members
  • 349 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Dimension C-137
  • Local time:04:37 AM

Posted 12 September 2016 - 11:11 AM

Do you have the model number and manufacturer?


- Daydreamed


#10 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 12 September 2016 - 11:13 AM

Installing the driver does not allow printers to be accessed. spoolsv.exe is still missing.



#11 opera

opera

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:37 PM

Posted 12 September 2016 - 12:01 PM

Try the Microsoft Fix-it for printer and print spooler issues

 

https://support.microsoft.com/en-us/kb/2793718

 

More info on this Fix-it here

 

https://blogs.technet.microsoft.com/askperf/2012/02/24/microsoft-fixit-for-printing/



#12 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 13 September 2016 - 09:29 PM

 

 

If you are redirected to this article when you click the Download button of a “Fix it” solution in a Microsoft Knowledge Base article, this means that the solution has been retired and is no longer supported. We recommend that you use one of the following diagnostics to resolve your software issues.

 

So yeah... that didn't work.



#13 opera

opera

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:37 PM

Posted 14 September 2016 - 12:56 AM

How about METHOD 2.. Step 1 (manual steps) from here

 

https://www.techsupportall.com/print-spooler-service-is-missing/



#14 jmhoffer

jmhoffer
  • Topic Starter

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Local time:06:37 AM

Posted 14 September 2016 - 08:09 AM

Web of Trust gives a malware warning for the website you've linked. The comments on the site specifically list a trojan. Not touching it.



#15 opera

opera

  • Members
  • 1,016 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:37 PM

Posted 14 September 2016 - 01:08 PM

Virustotal scan result for techsupportall website

 

https://www.virustotal.com/en/url/22eb37c2f0fe8fa8814e0e7ddfa666036537c9f8243f638e24b50e395906af5c/analysis/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users