Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't create more than one partition in SD


  • Please log in to reply
3 replies to this topic

#1 UNATCOPres

UNATCOPres

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 10 September 2016 - 10:48 PM

I've been struggling with this for 3 days now.

Hello guys. The thing is that I need to have an SD with 2 partitions for internal storage on android. The wierd thing is, no matter what procedure I take, the second partition cannot be formated. I can create the partition, but I when I format it it ends up with the file system "Other".

MiniTool Result

I've tried with A LOT of procedures, a lot of programs, I read a lot of guides, and nothing works.

This is all the info I can provide:

  • First partition works well in every case, I can read and write in it.
  • If second partition is Primary, file system is ALWAYS "Other" and NO free space left (all space marked as used), but if partition is logical, it does not even create it (updates as unallocated after commitment, as if nothing ever happened).
  • That "Other" partition is not recognized by nothing, and there is no way I can explore it.
  • I've tried in Windows 7 64 bits, Linux GParted Environment, Android 6.0 Marshmallow and Android 4.4 Kitkat.
  • I've tried in 3 devices: A PC, a Notebook and Moto E android with stock rom and CM 13.
  • I have 2 MicroSD, Kingston 16 GB Class 4 and Kingston 16 GB Class 10. All the procedures where repeated in both SD cards, so I discard the SD being broken.
  • I've used MiniTool Partition Wizzard, Acronis Disk Director Suite, EaseUS Partition Master and Paragon Hard Disk Manager on windows and AParted, Apps2SD: All in one tool and Parted4Android in Android (As well as GParted).
  • Tried both MBR and GTP. Same issue.
  • Tried FAT16, FAT32, NTFS, ext2, ext3 and ext4 in both first and second partition in MBR and GTP, primary and logical (ALL combinations, yes, a LOOOOT of formatting :3)
  • If third, fourth (and so on) partitions are created, the same as second partition happens.
  • I can succesfully create a second partition in a USB PenDrive.

Tried for example this: Created 2 partitions as FAT32, as always second partition marked as "Other", entered the first partition from windows, created a file. After that I switched the partitions with wasp. Once the other partition was active, when I tried to enter windows said "Drive X has no format, want to format?" Yes "Could not format X".

So, WHAT in the world am I supposed to do? D:

Thanks in advance guys :3 And sorry for my bad english.



BC AdBot (Login to Remove)

 


#2 Bailifei

Bailifei

  • Members
  • 109 posts
  • OFFLINE
  •  
  • Local time:05:58 PM

Posted 19 September 2016 - 09:09 PM

If I need a space on the SD card, I create a folder and the files go there. 



#3 JohnC_21

JohnC_21

  • Members
  • 24,819 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:58 PM

Posted 19 September 2016 - 10:13 PM

Windows will only recognize the first primary partition on a removable device. See the following on how to make Windows see both partitions. It's possible your USB flash drive is detected as "Local Disk". Some flash drives such and the earlier Sandisks would be detected as a Local Disk and not a Removable device.

 

http://superuser.com/questions/975900/sd-card-second-partition-not-recognized

 

This may also help.

 

http://forum.xda-developers.com/showthread.php?t=1585572

 

http://woshub.com/removable-usb-flash-drive-as-local-disk-in-windows-7/

 

Android is based on linux so if you create two Fat32 partitions on the SD card with Gparted Live CD both partitions should be detected by Android.



#4 vicmatmar

vicmatmar

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 03 March 2017 - 11:19 AM

I've run into the same problem.  I can create fat32 and ext4 partitions on some SD cards but not others.  So I'm inclined to believe some SD cards have a limitation... 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users