Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

LSASS.exe causes memory leak on Windows 10


  • Please log in to reply
No replies to this topic

#1 Tassadar-

Tassadar-

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:50 PM

Posted 08 September 2016 - 05:21 AM

Hi all,

I'm experiencing a problem in the office's server since I installed Windows 10. The problem is a well-known one with LSASS.EXE, and I've found that it's docummented and there are patches for Windows Server 2012, Windows 8.1 and Windows 7: LINK

My problem is there is no information about this problem on Windows 10.

The computer works like a charm... until lsass.exe starts taking more and more RAM. When it takes the whole 16GB the computer works awful and has to be restarted.

I attach some screenshots:

98e2fc502226713.jpg

Memory Usage:

b964f1502226705.jpg

CPU:

91cc03502226700.jpg


7fd903502226703.jpg

40a6ee502226709.jpg

The computer is a server but has no active directory, it's a common lan with four computers and the server has (among other functions) a ERP that uses SQL 2016 with a database.

Since I saw a reference to Named Pipes I tried to disable in "cliconf.exe" but it didn't solve the problem:

 

41a3fb502232080.jpg


I Found some information about memory leaks in windows 10 (not related to LSASS but "Windows Network Data Usage Monitoring Driver", so I modified registry in this way:

Navigate to Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Ndu and then from the right hand section of the window double click Start in order to be able to edit the Value data setting.  It will probably be 2 but changing this to 4 will disable the ndu.

Server specs:

-i7 Haswell @4,5 ghz
-Asrock Z97 extreme4 motherboard
-16 GB RAM DDR3 2400mhz
-Integrated VGA
-Raid 0 SSDs

Can anyone help me with this? I tryed Windows Performance Recorder Tool but it gave me not information to determine what is causing LSASS.EXE have this issue.

Regards and many thanks in adavance.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users