Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problems with display after hardware upgrade (Screen Strobing, etc.)


  • Please log in to reply
9 replies to this topic

#1 sheffielle

sheffielle

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:42 PM

Posted 07 September 2016 - 12:41 AM

Hello,

 

My Problem:

  1. I have my computer hooked up to my TV as a monitor via HDMI but no matter what I try, it always boots in PC mode until I sign in to Linux so I have to keep it hooked up via VGA as well and switch back and forth between inputs.
  2. Also, upon logging into Linux, PC mode (via VGA) goes black for a bit, varying in time.
  3. The HDMI input will sometimes strobe uncontrollably until I change the TV input to PC and then back to HDMI. I have found that the most reliable trigger for this is opening "Display" (settings) in System Settings
  4. Sometimes I get pink lines all over the screen for a few seconds and the display image gets twisted and contorted
  5. Lastly, when Linux mint is booting, some long "Dell" message appears horizontally across the screen but strobes too quickly for me to read.

I have tried looking into all of my TV's settings to see if that is causing the issue, but have found nothing that helps. Since I have a VGA port on my TV as well I suppose I could tinker with the settings again to make this the only Display Source, but one of the main perks of getting a new GPU was being able to use an HDMI connection like I do on my other devices.

 

Precursor: I recently started using an old Dell Inspiron530 again that was still running windowsXP and infested with malware. I cleared the Hard Drive to start from scratch and downloaded Linux Mint 18 Cinnamon 64-bit, and have been very impressed with this operating system, but I am definitely still adjusting to the differences.

 

This computer was unable to run even the simplest Internet games without extreme lag and the occasional crash. I have to run some games for a few of my college courses right now so I decided to upgrade my system a bit.

 

Current System: (new parts bolded)

  • Q6600 Processor (Core2Quad @2.4)
  • OFM586 Motherboard w/ 2Gib DDR2 RAM (Pathetic I know)
  • Sandisk Ultra II 240Gib SSD for booting
  • OEM 320Gib HDD for storage
  • Rosewill RD 450-2DB Power Supply Unit
  • EVGA GEFORCE GTX 750Ti GPU

I installed all the hardware, re-installed my OS on the SSD and cleared the HDD. I then went to install the Driver for the GPU (which came on a DVD-R) but of course, said driver is a .exe file (only thing that gets me frustrated at Linux right now).

So, I googled an answer, found a guide showing how to use Linux's recommended driver for the GPU (NVIDIA 361.42 for Linux-x86_64) and installed it.

 

This is my first time ever changing out hardware on a computer, so I am a bit lost at this point. Any help would be greatly appreciated!
 


Edited by sheffielle, 07 September 2016 - 12:53 AM.


BC AdBot (Login to Remove)

 


#2 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:09:42 PM

Posted 08 September 2016 - 12:35 PM

Did you add a GPU? or did you replace/upgrade a GPU?

I'm just a bit confused. Is the VGA an onboard video and the HDMI is from the 750ti?

If so, you may need to go into the BIOS and disable onboard video so that it will always boot using the 750ti GPU.


sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 


#3 sheffielle

sheffielle
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:42 PM

Posted 08 September 2016 - 08:09 PM

Sorry, yes I added a GPU, before that it only ran an integrated graphics card.

 

This GPU came with 3 output ports:

  1. HDMI
  2. DVI-I (with an included DVI to VGA adapter, which is what I was referring to when I said VGA)
  3. Displayport

So to answer your question, they are both coming from the 750ti.

 

Also, I went into BIOS previously to try that, and the closest setting I could find to that was along the lines of: "startup using PCI-ex first"(which I selected since my GPU is on the PCI-E slot) or "startup using PCI-1 or PCI-2 first"

 

I tried updating my BIOS (from version 1.0.2 to 1.0.18) expecting a large change in options, (like perhaps enabling AHCI instead of only RAID and IDE options to accommodate my new SSD) but the only change I have been able to notice since then is the DELL logo is updated when booting the computer. Big disappointment



#4 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:09:42 PM

Posted 08 September 2016 - 08:17 PM

Are you having the same problem with an actual monitor? Chances are, it's an issue with the TV and not the PC itself. The frequency/refresh rate are probably not matched.
Try going to the nvidia control panel and play around with the settings there for your TV (if the GPU even detects it).

Edited by badr0b0t, 08 September 2016 - 08:19 PM.

sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 


#5 sheffielle

sheffielle
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:42 PM

Posted 08 September 2016 - 08:37 PM

I'm not sure, this is my only display with an HDMI port. The TV claims to be 1080p so I put the settings to 1920x1080 @60hz on the nvidia control panel.

Sidenote: the control panel recognizes my TV, but claims that it is 19" (it is a 60" TV) not sure if that could be causing some issues.

 

I will try changing the TV settings and see if that helps



#6 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:09:42 PM

Posted 08 September 2016 - 08:46 PM

I'm not sure, this is my only display with an HDMI port. The TV claims to be 1080p so I put the settings to 1920x1080 @60hz on the nvidia control panel.

Sidenote: the control panel recognizes my TV, but claims that it is 19" (it is a 60" TV) not sure if that could be causing some issues.

 

I will try changing the TV settings and see if that helps

I am 99% sure it's the TV. Don't try to fix your PC. It's not broken.


sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 


#7 sheffielle

sheffielle
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:42 PM

Posted 08 September 2016 - 09:10 PM

Alright Ill try and do some research on the TV model and see if I can find a fix.

Thank you for your time, I appreciate the help!



#8 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:09:42 PM

Posted 08 September 2016 - 09:54 PM

I am not saying your TV is broken. Most TVs do work as PC monitors but they are not designed to be used for that specific purpose and the high demands of the graphics card may not be being met.

sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 


#9 sheffielle

sheffielle
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:08:42 PM

Posted 08 September 2016 - 10:10 PM

Yeah I know I understand, I was just hopeful that there was a setting that could be changed to stop the strobing problem. It seems the TV is trying to auto-adjust rapidly when certain processes occur on the computer, for whatever reason but I have gone all throughout the TV menu and see no options to toggle the auto-adjust.

I will just be sticking to the VGA for awhile, it gets the job done



#10 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:09:42 PM

Posted 08 September 2016 - 10:20 PM

The PC may be reading the TV wrong in terms of recommended resolution. Try to lower down the resolution on Display Settings on the PC and find out which resolution will fix the strobing issue.

sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users