Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Toshiba Satellite doesn't turn on when on only battery


  • Please log in to reply
No replies to this topic

#1 TrishaK

TrishaK

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:07:58 PM

Posted 05 September 2016 - 11:51 PM

Hi all...I have a Toshiba Satellite C55t-C. It has Windows 10 that came installed. I just noticed that it will not turn on when the AC is disconnected and only the battery is in. Hermine is coming through here right now, and we had a little power interruption. The laptop shut off, and it made me wonder why the battery didn't keep it on. I disconnected the AC cord and tried turning it on, and it didn't work. Thinking more about it, I realized that I have noticed this before, but never really paid much attention to it before, so it wasn't a power surge or anything that did it, it was doing it already.

 

I've been searching for a fix, and have seen over and over to disconnect power, remove battery, hold power button for 30 seconds, reconnect battery. This hasn't worked for me. I've done it now 5 or 6 times, holding the button down longer each time, up to almost a minute and a half. I also saw someone suggest checking the connectors to make sure they're not clogged with lint or dust, so I did that too while I had it all apart. There was a tiny bit of dust around the edges of the battery, but none on the connectors. I cleaned them up anyway, but it didn't seem ton help. It works fine with the AC connected, and the taskbar tells me the battery is charging, but the computer just doesn't turn on without the power cord. If I unplug the cord right now or if the power flickers again, it will shut off. I've never had this problem with any other laptop before.

 

I also saw suggestions about some other kind of battery - CMOS, I think? I'm not very computer savvy, so I don't know what that is. If it's something I can get at and fix myself, I would do it if I had some sort of instructions, but as of this moment I'm pretty clueless.

 

Can someone tell me what else I can try to get it working on the battery? If we lose power we won't have any way to get online except our phones, which will die before power comes back for sure, and that makes me a little nervous. Any help at all will be greatly appreciated! Thanks in advance!



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users