Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox Browser Doesn't Clear Cache or History as Instructed


  • Please log in to reply
7 replies to this topic

#1 wdrbbq

wdrbbq

  • Members
  • 267 posts
  • OFFLINE
  •  
  • Local time:09:06 AM

Posted 31 August 2016 - 02:54 AM

I have a question about Clearing the Cache and Browsing History Upon Closing with Firefox. I have gotten into the Settings and have instructed Firefox to clear the cache and browsing history upon closing by going to Tools>Privacy>Clear History When Firefox Closes. From there I click on Advanced>Settings for Clearing History, where I check both Browsing and Download History and Cache.I have been careful to make sure no other setting contradicts that. Yet, if I run C Cleaner after closing my Firefox browser, it can take up to thirty five minutes for it to clear the Firefox Internet Cache, with most time taken in C:\Users\AppData\ while clearing over 9,000 files . Am I doing something wrong or is Firefox ignoring me? This has been the case with all versions of Firefox since at least Version 38.0. I'm less interested in opinions about Firefox and more interested in solving the problem. Thanks.



BC AdBot (Login to Remove)

 


#2 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:06 AM

Posted 31 August 2016 - 04:00 AM

Do you have Firefox 38.0?
The current version is 48.0.2
I ask it, because Firefox doesn't have those buttons and options. Or, I can not hardly understand about what kind of buttons you're talking about.
 
But it is true that if you have a cache enabled, by default the cache files are saved in the  AppData\Local\Mozilla\Firefox folder. However, can disable cache at all. And as well, you can send cache files to any place. It is your choice.
And it is also true that the default location cleans Ccleaner perfectly, but if You change the location, then You must write also new rule for the CCleaner.
And it is also true that there can be a lot of files. By default it is and an infinite number of files and the size is 358,400 bytes, but you can change it if you want. You can set it beginning from 0 to what ever You want. These files are used only during one session  and then they are already obsolete. 


#3 wdrbbq

wdrbbq
  • Topic Starter

  • Members
  • 267 posts
  • OFFLINE
  •  
  • Local time:09:06 AM

Posted 31 August 2016 - 05:22 AM

Firefox does indeed have those buttons. Access them from the tools menu. It's Firefox 46.0. So, why not tell me how to disable the cache?



#4 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:06 AM

Posted 31 August 2016 - 07:02 AM

There is two methods. If is or was already installed or You have the profile folder, open it and find these two lines (below) in file prefs.js

This file located in AppData/Roaming/Mozilla/Firefox/Profiles/yourprofilename.default/prefs.js
------------------------------------------------------------------------------------------------------------------------------

user_pref("browser.cache.disk.capacity", 358400);

user_pref("browser.cache.disk.enable", true);   - (NB! this may not be in Yours version, then simply add it)

------------------------------------------------------------------------------------------------------------------------------

 

and change like these :

--------------------------------------------------------------------

user_pref("browser.cache.disk.capacity", 0);
user_pref("browser.cache.disk.enable", false);
--------------------------------------------------------------------
You can use for example Notepad or some other text editor. Firefox must be closed before You open this file.
NB! Be careful to send with correct name ie prefs.js (You must select in notpad Save as => All Files (*.*) => UTF-8 (not ANSI or something else))
 
The other method:
Open Firefox
to the URL area write about:config and then ENTER
there you have click on button "I'll be careful, Ipromise!"
then write to the search area browser.cache.disk.capacity and change value area 358400 => 0
then enter browser.cache.disk.enable and change true => false
Thats all, simply close window and restart Firefox
 
This works with Firefox, Cyberfox, Waterfox, Pale Moon, Comodo IceDragon etc, But they have their own profile folder, only Waterfox uses the same Firefox profile, if You haven't changed it.

Edited by kaljukass, 31 August 2016 - 07:12 AM.


#5 wdrbbq

wdrbbq
  • Topic Starter

  • Members
  • 267 posts
  • OFFLINE
  •  
  • Local time:09:06 AM

Posted 31 August 2016 - 07:32 AM

Ok, we're getting there. I got to the line in about:config which says: BROWSER.CACHE.DISK.CAPACITY USER SET INTEGER 358400

However, I see no way to change the value to 0. How do I do that? Thanks for your help.



#6 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:06 AM

Posted 31 August 2016 - 07:50 AM

Ok, we're getting there. I got to the line in about:config which says: BROWSER.CACHE.DISK.CAPACITY USER SET INTEGER 358400

However, I see no way to change the value to 0. How do I do that? Thanks for your help.

Two left mouse click on the value 358400, if table opens, change and OK



#7 wdrbbq

wdrbbq
  • Topic Starter

  • Members
  • 267 posts
  • OFFLINE
  •  
  • Local time:09:06 AM

Posted 31 August 2016 - 08:00 AM

Ok. It worked. I changed the value to 0 and false respectively. Thank you. I appreciate your expertise and promptness. Thanks again.



#8 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:06 AM

Posted 31 August 2016 - 08:10 AM

Ok. It worked. I changed the value to 0 and false respectively. Thank you. I appreciate your expertise and promptness. Thanks again.

Good luck to You, if You have problems, You're welcome to ask.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users