Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Some of My USB Ports Have Stopped Working

  • Please log in to reply
No replies to this topic

#1 ArloRosetta


  • Members
  • 1 posts
  • Local time:08:50 PM

Posted 30 August 2016 - 07:14 PM

   So my problem began while playing a game. I was playing and all of a sudden the sound cut out. I could not figure out why, and after a few minutes I realized my mouse was not working either. My computer is using an Ibuypower tower and it contains two separate areas for USB ports. One of them contained both my mouse and my USB headset. The other area (which has two ports) works perfectly fine. This back area has both USB 3.0 and 2.0 ports (2 of each, so 4 altogether). I went into my playback devices (windows 10) and saw that it said they were all not plugged in, as shown in the attached photo. I have no idea what happened and I'm not very good with computers. I went into my tower to see if it was a loose cord or something and quickly realized I was in over my head. I'm hoping it's something that can be fixed without having to take it into a repair shop, but if it is please tell me. All help is appreciated.


Attached Files

BC AdBot (Login to Remove)



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users