Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Javascript not working


  • Please log in to reply
19 replies to this topic

#1 vlasko

vlasko

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:30 PM

Posted 30 August 2016 - 12:34 PM

Operation system:  Windows 10

Browser:  Internet Explorer 11

 

Problem:  Javascript buttons and hyperlinks are non-functional.  I don't get an error message.  They just don't do anything.  If I go to websites that detect if Javascript is enabled, they give confirmations, e.g. enable-javascript.com .   I'm not able to use browsers other than Internet Explorer because they are not supported for the websites I need to use for my job.

 

What I've tried:  

1)  Resetting internet explorer and resetting personal settings. 

2)  Adding sites as trusted sites.  

3)  I made sure that active scripting is enabled in the "Scripting" section of internet options

4) Temporarily disabled firewall.

5)  SFC and Chkdsk scans

6)  I tried running IE with extensions off.

7)  If I log in through someone else's computer, everything works.  The company website does use asp

 

Any suggestions?  Thanks.



BC AdBot (Login to Remove)

 


#2 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:30 AM

Posted 30 August 2016 - 04:10 PM

If You have not installed something, what can disable or block scripts, then simply restore IE default settings and restat IE. Should work.

http://www.technipages.com/internet-explorer-enabledisable-javascript



#3 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:12:30 PM

Posted 30 August 2016 - 04:39 PM

If You have not installed something, what can disable or block scripts, then simply restore IE default settings and restat IE. Should work.
http://www.technipages.com/internet-explorer-enabledisable-javascript

 
He has already tried that. Did not work.
 

What I've tried:  
1)  Resetting internet explorer and resetting personal settings. 
 
3)  I made sure that active scripting is enabled in the "Scripting" section of internet options



#4 JohnC_21

JohnC_21

  • Members
  • 24,418 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 PM

Posted 30 August 2016 - 05:05 PM

Browse to C:\Windows. Hold the shift key and right click on the SysWoW64 folder.

 

Type the following commands then reboot

regsvr32 vbscript.dll    
regsvr32 jscript.dll      


#5 kaljukass

kaljukass

  • Banned
  • 291 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:30 AM

Posted 30 August 2016 - 05:42 PM

 

He has already tried that. Did not work.
 

What I've tried:  
1)  Resetting internet explorer and resetting personal settings. 
 
3)  I made sure that active scripting is enabled in the "Scripting" section of internet options

 

Well, as you may have read, then You must know, this is the problem, that is not allowed. And if in the settings is enabled, it is necessary to clarify what exactly prohibits and how.
It would make sense to include some examples in which it manifests,  it happens only on some websites or everywhere, happens with all browsers, or only in IE and so.

And where is your recommendation?



#6 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Members
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:12:30 PM

Posted 31 August 2016 - 10:54 AM

My recommendation would have been to look in Internet Options and to reset Internet Explorer. However, since he/she said it had been tried and did not work I did not post that suggestion.

I was simply pointing out the obvious.

#7 vlasko

vlasko
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:30 PM

Posted 31 August 2016 - 02:41 PM

 

Browse to C:\Windows. Hold the shift key and right click on the SysWoW64 folder.

 

Type the following commands then reboot

regsvr32 vbscript.dll    
regsvr32 jscript.dll      

Thank you.  Javascript links are functional now.



#8 JohnC_21

JohnC_21

  • Members
  • 24,418 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 PM

Posted 31 August 2016 - 02:53 PM

Your Welcome, glad the problem is now resolved and thanks for the update.



#9 xavi0ur

xavi0ur

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:30 AM

Posted 21 November 2016 - 12:09 AM

hi, i have same problem. I'm using windows 10, and i using firefox, chrome, opera, edge. i already tried use this solution. but the button still not working. i tried using another computer, and there's no problem.

 

any suggestion? thanks

 

 

Browse to C:\Windows. Hold the shift key and right click on the SysWoW64 folder.

 

Type the following commands then reboot

regsvr32 vbscript.dll    
regsvr32 jscript.dll      

 

 



#10 JohnC_21

JohnC_21

  • Members
  • 24,418 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 PM

Posted 22 November 2016 - 08:39 AM

I am not sure what you mean by the button not working. Can you post an image? Have you tried all the steps in the OP's first post?



#11 xavi0ur

xavi0ur

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:30 AM

Posted 22 November 2016 - 09:36 AM

I am not sure what you mean by the button not working. Can you post an image? Have you tried all the steps in the OP's first post?

 

yup.i already tried it.

 

like the image below, the option not showing

 

and in another site, like groupon, not automatically calculate the sum, and when i tried to move the next step, the button not working (in image)

 

thanks

Attached Files



#12 JohnC_21

JohnC_21

  • Members
  • 24,418 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 PM

Posted 22 November 2016 - 10:18 AM

If you start firefox with no addons do you get the same problem? Help > Restart with Addons disabled.

 

If there is still a problem open a command prompt and type sfc /scannow



#13 xavi0ur

xavi0ur

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:30 AM

Posted 22 November 2016 - 10:23 AM

If you start firefox with no addons do you get the same problem? Help > Restart with Addons disabled.

 

If there is still a problem open a command prompt and type sfc /scannow

yes, still got the problems

and i already did the scan.

not only firefox, all browser in my computer have same problem. so i think the problem in my windows.



#14 JohnC_21

JohnC_21

  • Members
  • 24,418 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:30 PM

Posted 22 November 2016 - 10:48 AM

I am not sure what else to try. In Windows 10 there is a reset with the option to keep your files but any programs would need to be reinstalled. 

 

Have you tried in Safe Mode with Networking?

 

http://www.digitalcitizen.life/4-ways-boot-safe-mode-windows-10


Edited by JohnC_21, 22 November 2016 - 10:48 AM.


#15 xavi0ur

xavi0ur

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:12:30 AM

Posted 22 November 2016 - 11:07 AM

i just tried in safe mode, and  still not working.

:mellow:  :(






3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users