Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My Computer Won't Turn On


  • Please log in to reply
1 reply to this topic

#1 ComputersRCool

ComputersRCool

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:01 AM

Posted 26 August 2016 - 10:07 AM

Hello,

 

I have an Acer Extensa 4420. It's a really old computer, but it has been working up until about 2 months ago. I had put it away in storage due to not having a need for it anymore. (It was a bit slow.) Well, I went to turn it on one day, about two months ago, and it simply wouldn't. Now, this pattern does change. (I have the cord hooked to it to ensure that it is not the battery. The charging light comes on.) Sometimes the power button will turn green and then instantly blink back off. More often, though, the power light will turn on, the fans will start whirring, etc., and then it will shut back off. It will then turn back on, as if rebooting itself, and then shut off entirely. During, this process, the screen never turns on. There are times when pushing the power button will not turn the computer on at all.

 

The screen on the Acer is beaten up. It appears as if there is a nick in a small black cord on the right side of the computer that connects to the screen. I just replaced the screen about a year ago, though. I have also already tried to reseat the ram modules by popping them out and putting them back in. This did nothing. I then tried replacing the CMOS battery. This also caused no change. I did put electrical tape on the nick in the screen cord, but I don't know if that is even helping much at all.

 

Does anyone have an idea as to what the issue could be? I don't have any on the information on this laptop backed up. I've had it for about 6 years.



BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:06:01 AM

Posted 27 August 2016 - 08:28 AM

As you've not had a response here, try posting over in the Internal Hardware forums (   

or in the Windows 7 forums (presuming that it has W7).


My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users