Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Devices not working + (Code28)&(Code 10)


  • Please log in to reply
No replies to this topic

#1 samg2000

samg2000

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:28 AM

Posted 25 August 2016 - 10:20 AM

A few days ago I was using my computer and I plugged my phone into one of the USB ports to charge it. All of the sudden my keyboard and mouse stopped working. At the time I luckily also had my Wacom pen tablet plugged in, so I was able to use it to get the ‘Devices and Printers’ section in the control panel and try to fix everything.

 

Under the properties>hardware tab of both my Dell USB Wired Entry Keyboard and Inland Gaming Mouse (07243), the device status was, “The drivers for this device are not installed (Code 28).” I tried to troubleshoot both devices, but the computer notified me that the drivers were not installed and that each device “doesn’t have a driver.” ... (?????)

 

I was honestly very confused as to how this had happened and how my tablet was working just fine despite also being a device(?). First I tried unplugging and plugging in the mouse and keyboard. Nothing changed. Next it made most sense to restart the computer. I did so, but yet again nothing changed.

 

Next I went back to the Devices and Printers page of the Control Panel. I removed the mouse as a device and unplugged it from the USB port. I put it back in with hopes that the mouse drivers would install automatically as I thought they should, but instead the device just showed up under the ‘Unspecified’ tab of the Devices and Printers section.

 

After that I went to properties>hardware>properties>general and clicked ‘Change settings,’ then ‘Update driver.’ I got a pop-up asking how I wanted to search for the driver software and I hit “Browse my computer for driver software,” and then, “Let me pick from a list of drivers on my computer.” Under the common hardware types I went to “Mice and other pointing devices,” and then under ‘Manufacturers’ and ‘Standard mouse types’ I installed the ‘Standard Serial Mouse.’

 

Another pop-up appeared, but this time it said, “Windows found driver software for your device but encountered an error while attempting to install it... The device cannot start (Code 10).” At this point the mouse was back under the ‘Devices’ tab of the Devices and Printers section.

 

After this I unplugged my mouse and plugged in a standard Dell mouse. It showed up under Unspecified. Next I tried a receiver for a wireless mouse. Again, Unspecified. Neither of them downloaded the drivers once plugged in.

 

By this time I was figuring that my computer was failing to properly read any device that was a mouse and (I assume) keyboard. I have no idea why this happened or what else I could possibly do to try and fix this. Please help!

 



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users