Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Diagnostic Policy Service is not running


  • This topic is locked This topic is locked
3 replies to this topic

#1 rumpled103

rumpled103

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:03:13 AM

Posted 24 August 2016 - 05:26 AM

I'm running Windows 7 Home Premium 64-bit. Ok, so I tried running the troubleshooter for the HomeGroup and it said that the Diagnostics Policy Service is not running. So I googled that and I found this video: I followed the instructions but it didn't do anything. I tried starting the Diagnostics Policy Service manually, but it didn't work. It gives me "Windows could not start the Diagnostic Policy Service service on Local Computer. Error 5: Access is denied." I even tried running it as admin, but still no luck.

 

The reason I'm trying to fix this is because I have two computers and two printers. If I go to the computer in one room and try to print something to the computer in the other room, it'll work. It'll show the print jobs in See What's Printing. But if I try to do it vice-versa, nothing happens. It shows up in See What's Printing on the computer that I chose to print from, but it doesn't show up in See What's Printing on the computer with the printer I was trying to print to.

 

I've searched around here and found this post:

I tried all of those things and I finally got it fixed:

go to start ,search and type:- cmd, right click on returned cmd.exe and select "run as administrator" at the prompt type:-


net localgroup Administrators /add networkservice
press enter then type:
net localgroup Administrators /add localservice
press enter then type:
exit
press enter and restart your computer

Open services and make sure the service is started.

 

from here: http://answers.microsoft.com/en-us/windows/forum/windows_7-update/diagnostic-policy-service-could-not-start-on-local/aa2d2042-6b5a-412f-b278-35af8a50c5c1

 

Now the issue is if I type those commands, it'll just give me

System error 1378 has occurred.

The specified account name is already a member of the group.

 


Edited by rumpled103, 24 August 2016 - 05:28 AM.


BC AdBot (Login to Remove)

 


#2 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:02:13 PM

Posted 24 August 2016 - 07:04 AM

First of all Diagnostic Policy Service service has nothing to do with print jobs Print Spooler service  spools print jobs and handles interaction with the printer.  If you turn off this service, you won’t be able to print or see your printers.

 

 

Tweaking.com - Windows Repair is a tool designed help fix a large majority of known Windows problems including; registry errors, file permissions, issues with Internet Explorer, Windows Updates, Windows Firewall and more. Download Tweaking.com - Windows Repair Tool and run the Tweaking.com - Windows Repair Tool from Safe Mode With Networking and  from Repairs tab click Open Repairs button. From opened Repairs window place check mark for  Reset Registry Permissions, Reset Service Permissions, Register System Files, Repair WMI, Repair Network, Repair Windows Firewall, Remove Policies Set By Infections, Repair Proxy Settings, Repair Windows Updates, Repair MSI (Windows Installer), Restore Important Windows Services, Set Windows Services To Default Startup,  Restore UAC (User Account Control) Settings, Repair Hosts File, Repair Performance Counters, Repair Volume Shadow Copy Service, Repair MDAC & MS Jet and Reset File Permissions check boxes and click Start Repair button.


Posted Image


#3 rumpled103

rumpled103
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:03:13 AM

Posted 26 August 2016 - 02:38 AM

See my new topic here: http://www.bleepingcomputer.com/forums/t/624852/i-still-cant-send-print-jobs-to-the-printer-in-the-other-room/



#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,755 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:13 AM

Posted 26 August 2016 - 05:01 AM

Since OP has begun a new topic on issues in another BC forum, this topic is closed to avoid confusion.

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users