Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB 3.0 Not working?


  • Please log in to reply
6 replies to this topic

#1 ac19189

ac19189

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:01:44 AM

Posted 15 August 2016 - 11:04 AM

So I have an HP Envy 700-327c that I just bought with no hard drive. So I dropped one in and installed a fresh copy of windows 7 jumped on the HP site downloaded the drivers and went to town. When I first installed windows I have six devices under device manager that needed drivers.

 

Blutooth Controller

Ethernet Controller

Network Controller

PCI Simple Communications Controller

SM Bus Controller

Universal Serial Bus (USB) Controller

 

After installing drivers PCI Simple Communication Controller and SM Bus Controller are the only drivers left that didnt seem to take.

So after hours of fighting with it I finally have all the drivers setup now I have a 5 in 1 card reader on this machine but couldnt see it so after messing with and clearing a few drivers and letting windows find the correct drivers they started working however usb 3.0 plugs dont work and I cant figure it out. They all have power but I dont get any response from the system that something plugged into them only 2.0 seems to work. I would imagine this is a driver issue but after clearing all the chipset, usb drivers and letting windows find the correct ones I still have no fix. Any help would be great.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,019 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:44 AM

Posted 15 August 2016 - 11:10 AM

Is there any yellow exclamation mark in Device Manager? Right click the device. Select Properties and under the Details tab select Hardware IDs in the dropdown box. Copy and Paste the first line into your next post.

 

I am not sure what is going on with HP but this is the second time I have come across their support site of a PC that has no drivers listed which is odd.



#3 ac19189

ac19189
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:01:44 AM

Posted 15 August 2016 - 12:26 PM

I do not have anything because I went hunting for all my drivers but I think I screwed one up and thats why usb 3.0 isnt working because my media card wasnt working as well until after I removed the drivers I had installed and let windows deal with it I made a list above of devices that had no drivers at the start of my fresh install meaning thoughs where the ones I had to find. Though judging by the issues im having it didnt solve much.



#4 OldPhil

OldPhil

    Doppleganger


  • Members
  • 4,123 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island New York
  • Local time:04:44 AM

Posted 15 August 2016 - 01:39 PM

I am guessing you have been to the link below, I have had good luck letting them find the correct drivers.

 

http://support.hp.com/us-en/drivers


Edited by OldPhil, 15 August 2016 - 01:40 PM.

Honesty & Integrity Above All!


#5 JohnC_21

JohnC_21

  • Members
  • 24,019 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:44 AM

Posted 15 August 2016 - 01:41 PM

If there was no yellow exclamation mark the only thing I can advise is to download the intel driver update utility and let it scan your hardware.

 

http://www.intel.com/content/www/us/en/support/detect.html

 

Believe it or not a poster at the HP forum had to go to an ASUS support page for his USB 3 driver as it uses the same H87 chipset.

 

http://h30434.www3.hp.com/t5/Desktop-Operating-Systems-and-Recovery/Envy-700-327c-drivers-for-Windows-7/td-p/3998082


Edited by JohnC_21, 15 August 2016 - 01:49 PM.


#6 ac19189

ac19189
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:01:44 AM

Posted 15 August 2016 - 03:30 PM

...WOW Days I have spent DAYS looking for a fix https://www.asus.com/Motherboards/H87PLUS/HelpDesk_Download/ v2.5 drivers for usb solved it. Thank you so much for that info JohnC



#7 JohnC_21

JohnC_21

  • Members
  • 24,019 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:44 AM

Posted 15 August 2016 - 03:33 PM

Glad that worked for you. A sad day for HP when you have to go to ASUS for the correct driver. The computer is not that old so I don't understand why HP no longer shows drivers on their support site. 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users