Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Default gateway doesn't appear in ARP table; DHCP does assign IP address


  • Please log in to reply
1 reply to this topic

#1 tchap199

tchap199

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:21 AM

Posted 07 August 2016 - 11:53 AM

Hi all, this is my first time posting on one of these forums so I apologize if I leave out any necessary information:

OS: Windows 8.1
Computer make/model: HP Envy dv7
Wi-Fi adapter: Qualcomm Atheros AR9485
Router type: Arris DG1670A
AV software: Avast Free

In the middle of the day yesterday my laptop lost the ability to connect to the Internet via the Wifi in my apartment building. It connects to other Wifi networks no problem, including an iPhone hotspot and public coffee shop Wifi; also, my other devices, including iPhone and Roku, have no trouble connecting to the Wifi in my building. So the problem is only between my laptop and this particular wifi router.

DHCP on this router does assign my laptop an IP address (192.168.0.11); the default gateway (192.168.0.1) and subnet mask (255.255.255.0) that my laptop receives are the same ones that my iPhone and other devices that connected successfully receive. But pinging the default gateway returns either (most commonly) a "Request timed out" or (occassionally) "Destination host unreachable."

I checked my ARP table using arp -a and it turns out that the default gateway is not being added to the ARP table; there is no entry for 192.168.0.1 in the table. I tried making a manual entry using:

netsh interface ip add neighbors "Wi-Fi" 192.168.0.1 [The router's MAC address]

and the entry was successfully added (confirmed by arp -a), but nothing else changed; pinging the default gateway still returned the same non-result.

I've tried disabling my firewall and AV shields; I've tried deleting the ARP cache with netsh interface ip delete arpcache.

The one thing I can't do is manually reset the router, because it's controlled by my landlord and I don't physically have access to the router box (I got the router's MAC address by looking at the ARP table for the iPhone that connected successfully). But since other devices can connect to the router with no problems, I'm not sure that would help anyway.

Thank you very much in advance for your help. I appreciate any advice given!



BC AdBot (Login to Remove)

 


#2 tchap199

tchap199
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:06:21 AM

Posted 07 August 2016 - 02:16 PM

Update:

 

I was able to reestablish Internet access by setting a static IPv6 address. For some reason, that allowed me to access the Internet over IPv4, but my Wi-Fi Status screen from the Network and Sharing Center still reports no Internet access over IPv6. Also, when I click on the "Details..." button on the Wi-Fi Status screen, there are about 170 "Temporary IPv6 Address"es listed (but there are not more being added).

 

Edit:

 

I've disabled IPv6 by unchecking its box on the "Wi-Fi Properties" screen. The Internet is still working fine. I guess the router is just incorrectly configured for IPv6, somehow?


Edited by tchap199, 07 August 2016 - 02:21 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users