Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Peripherals not Activating in OS


  • Please log in to reply
No replies to this topic

#1 Dragolien

Dragolien

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Surrey, UK
  • Local time:06:59 PM

Posted 30 July 2016 - 01:52 PM

Recently I installed W10 onto a separate hard-drive so that I could dualboot W7 and W10.

 

However once the installation finished and I went to load W7, I noticed that once I got onto the OS and the login screen, neither my keyboard nor mouse worked at all. The LEDs wouldn't change on the locks. After repeating this a few times, it seemed that once the BIOS was exited and the keyboard and mouse tried to restart, that they wouldn't activate like they should.

Weirdly if I mashed the mouse while it was dead, the LEDs would flicker. Taking the mouse out and plugging it back in would stop this, but it was reproducible once I restarted the computer.

 

I tried changing about the boot settings in the advanced BIOS menu including changing the initial drive that loaded and using safe mode.

Initially safe mode worked and I changed settings about in msconfig to see if it was a rogue service or startup program. On restart, the mouse and keyboard seemed to work fine once I re-enabled all the services.

 

Feeling like this wasn't the source of the problem, I loaded up W10 again, then back to W7. Surprise, the peripherals stopped working. This time even with safe-mode (and networking if it makes a difference) the mouse and keyboard didn't work.

 

Following another fiddle in the BIOS, but nothing I hadn't done before, W7 worked again in safe mode. This time I left all the services on, and it continued to work after restart.

 

Once more I loaded W10, then W7 in regular and safe mode. Both times the peripherals failed.

But once I entered the advanced BIOS again, W7 resumed normally. I have a feeling that this is what reset the problem.

 

Any clue to what is going on? Right now I can use my computer, but it seems touch and go.

 

If it makes a difference, my keyboard is a Corsair K70R and my mouse is a Corsair M95. The motherboard is a GIGABYTE Z87 series. This issue hasn't occured in W10 so far.


Edited by Dragolien, 30 July 2016 - 02:22 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users