Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Is my CPU running at full speed or is this an issue?


  • Please log in to reply
9 replies to this topic

#1 ScarXL

ScarXL

  • Members
  • 105 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:EU, RO
  • Local time:05:52 PM

Posted 25 July 2016 - 09:02 PM

PC Specs (because it's necessary):

- OS: Microsoft Windows 8.1 Pro 64 bit

- CPU: Intel® Pentium® G620 2.60 GHz Dual-Core

- GPU: NVIDIA GeForce GT 610 1024MB DDR3

- RAM: 4 GB of DDR3 RAM

- PSU: Free Silent 500W Power Supply

- Motherboard: ASRock H61M-DGS R2.0

 

I was looking through HW Monitor and I saw that both of my CPU clocks are running at 1995 MHz rather than my actual CPU's speed.

 

6e2abddc901c44c3ba2aea70873a5e11.png

 

I'm not good with hardware so correct me if I'm wrong.

 

Intel SpeedStep is disabled in BIOS and Power Saving Plan is on High Performance. Task Manager shows that the CPU is running at 2.59 GHz (2.60) but HWMonitor shows that instead.

 



BC AdBot (Login to Remove)

 


#2 LiamP5

LiamP5

  • Members
  • 330 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York City, New York, USA
  • Local time:06:52 AM

Posted 25 July 2016 - 09:17 PM

Download everest and cpu-z look the cpu specification which shows the correct information.
To achieve something first try
to get the knowledge about it.
Be happy, always try
for it
.......................Lets do it and learn from bleepingcomputer.com Never feel alone

#3 ScarXL

ScarXL
  • Topic Starter

  • Members
  • 105 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:EU, RO
  • Local time:05:52 PM

Posted 25 July 2016 - 09:21 PM

8125c0823d1743e3905e3bbdf8ea8a70.png

 

Is this correct? My CPU should be running 2.60 GHz.



#4 LiamP5

LiamP5

  • Members
  • 330 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York City, New York, USA
  • Local time:06:52 AM

Posted 25 July 2016 - 10:21 PM

Once you go in bios and look for flexibility option if that enable then disabled it.
To achieve something first try
to get the knowledge about it.
Be happy, always try
for it
.......................Lets do it and learn from bleepingcomputer.com Never feel alone

#5 ScarXL

ScarXL
  • Topic Starter

  • Members
  • 105 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:EU, RO
  • Local time:05:52 PM

Posted 26 July 2016 - 01:09 AM

I've looked through the entirety of the BIOS and there is no Flexibility option anywhere.

 

My motherboard is ASRock H61M-DGS R2.0.



#6 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,356 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:09:52 AM

Posted 26 July 2016 - 03:33 AM

It could be just some random quirk of somekind

Are your temps high?

Is your computer crashing at random?

If not I say its probably nothing to worry about


Edited by MadmanRB, 26 July 2016 - 03:35 AM.

You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

8spxh0-6.png


#7 LiamP5

LiamP5

  • Members
  • 330 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York City, New York, USA
  • Local time:06:52 AM

Posted 26 July 2016 - 11:20 AM

Yeah i agree with MadmanRB. You don't need worry about that. But we will try to find out the matter.

I've looked through the entirety of the BIOS and there is no Flexibility option anywhere.

My motherboard is ASRock H61M-DGS R2.0.

If i'm sure this is processor in which shows that it have 2.60 ghz clock speed. If you are not satisfied then download Sandra lite which is most advanced software to know all specs about pc.
To achieve something first try
to get the knowledge about it.
Be happy, always try
for it
.......................Lets do it and learn from bleepingcomputer.com Never feel alone

#8 ScarXL

ScarXL
  • Topic Starter

  • Members
  • 105 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:EU, RO
  • Local time:05:52 PM

Posted 26 July 2016 - 01:32 PM

My PC is not crashing, in fact I barely experience BSoD's.

My temperatures on the CPU are between 37-43 celsius.

Everything in my PC has good temps.

 

I just wanted to make sure, thanks.



#9 MadmanRB

MadmanRB

    Spoon!!!!


  • Members
  • 3,356 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:No time for that when there is evil afoot!
  • Local time:09:52 AM

Posted 26 July 2016 - 01:45 PM

Nothing wrong with checking, you are protecting your investment after all.


You know you want me baby!

Proud Linux user and dual booter.

Proud Vivaldi user.

8spxh0-6.png


#10 jonuk76

jonuk76

  • Members
  • 2,182 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:02:52 PM

Posted 27 July 2016 - 11:51 PM

 

Intel SpeedStep is disabled in BIOS and Power Saving Plan is on High Performance. Task Manager shows that the CPU is running at 2.59 GHz (2.60) but HWMonitor shows that instead.

 

 

I would tend to leave SpeedStep on. Some overclockers disable it, but other than that there is no advantage to having it run at full speed all the time as it just generates more heat and uses more power.  With SpeedStep enabled it should run at full speed only when under load.  It also reduces voltage when the processor is clocked down.

 

I don't know what your BIOS is like, but usually there are processor speed setting options.  You might want to make sure that the multiplier is set at the correct number (26x).


7sbvuf-6.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users