Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

problem VLC player in Linux 18


  • Please log in to reply
13 replies to this topic

#1 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 05:03 AM

Successful install of Linux mint 18......spoiled by sub par performance of the vlc player

 

The screen size is lacking....in full screen mode only a 20cm x 10cm (8" x 4") rectangle........on my 60cm screen (24") it looks a little bit lost !

 

I have played with screen resolution and zoom etc..all to nbo avail

 

I got the same result from sm player....precisely the same.

 

I then tried the default (video)...and it performs properly in terms of screen size.

 

Any ideas ?


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:50 PM

Posted 21 July 2016 - 05:11 AM

I would try starting vlc from the terminal, try to switch to full screen, then copy any error messages from the terminal into a post here.

#3 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,933 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:03:50 AM

Posted 21 July 2016 - 05:28 AM

Cant you manually resize the window?

 


Edited by NickAu, 21 July 2016 - 05:31 AM.

Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#4 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 06:16 AM

@ Al1000 

 

to summarise...I typed 'vlc' in to terminal...vlc opened....i clicked on file and found a video to open.....it opened promptly and played. Screen size small (same)

 

Terminal produced this::

 

brian@brian-desktop ~ $ vlc
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000002236148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
QObject::~QObject: Timers cannot be stopped from another thread

 

@NickAu   ?

 

o9etdk.jpg


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

#5 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,933 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:03:50 AM

Posted 21 July 2016 - 06:24 AM

oops try now


Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#6 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 06:34 AM

tried that....I am still left with a "box" in the middle of a huge black area

 

15cesdw.jpg

 

amrxmw.jpg


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

#7 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 06:37 AM

and when I minimize that screen to bring up firefox browser with the BC page.....the "screen" stays emblazoned in the middle of the browser window.......weird !!...

 

I actually have to close the video window completely to be able to see and use the browser


Edited by Condobloke, 21 July 2016 - 06:37 AM.

Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

#8 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:50 PM

Posted 21 July 2016 - 06:44 AM

In vlc, under Tools --> Preferences --> Input / Codecs, what is Hardware-accelerated decoding set to? If it's set to automatic or VDPAU, try setting it to VA-API video decoder via X11 and see if that fixes the problem. (click "save" after changing the setting)


Edited by Al1000, 21 July 2016 - 06:46 AM.


#9 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 06:58 AM

It was set to Automatic......I changed it to VA-API video decoder via X11, clicked on save....closed the video and restarted it....No Change.

 

From my own reading there was a problem reported with libvdpau on THIS page....     no resolution there, but at least it is a known bug...?


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

#10 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:50 PM

Posted 21 July 2016 - 07:27 AM

I found someone else saying it had been reported as a bug, so thought using a different decoder might do the trick.

 

The only other thing I can think of is to try changing the output setting for Video, under Tools --> Preferences --> Video.



#11 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,933 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:03:50 AM

Posted 21 July 2016 - 07:38 AM

Try clicking video then always fit window, or  try hitting f11

 

I am watching Gods of Egypt


Edited by NickAu, 21 July 2016 - 07:39 AM.

Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#12 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 07:41 AM

I went to Tools --> Preferences --> Video.....and after much fiddling around, I UNTICKED the "Accelerated video output(Overlay)" box......and voila!...I have the ability to view full screen !!

 

I have no idea why that made the difference.


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy

#13 Al1000

Al1000

  • Global Moderator
  • 7,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:50 PM

Posted 21 July 2016 - 07:46 AM

Pleased to hear it's working!



#14 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,816 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:50 AM

Posted 21 July 2016 - 07:48 AM

Thank you both for your input and help

 

Brian


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

It has been said that time heals all wounds. I don't agree. The wounds remain. Time - the mind, protecting its sanity - covers them with some scar tissue and the pain lessens, but it is never gone. Rose Kennedy




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users