Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Touch issues in Lubuntu


  • Please log in to reply
20 replies to this topic

#1 PrimeMinisterX

PrimeMinisterX

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 18 July 2016 - 07:23 PM

As some of you already know, I recently switched over from Win 10 to Lubuntu on one of my laptops.

The problem I'm having however is that the touchpad is super-sensitive. I can barely type a sentence without the cursor jumping all over the place because my palm hit the touchpad with just the lightest touch. It's so bad that if I can't figure out a way to fix it then I'm probably going to have to go back to Win 10.

I found this article and the "Disable touchpad while typing" option seems like it might be helpful:

https://help.ubuntu.com/community/Lubuntu/Mouse

But I apparently don't know how to type the commands into the terminal.

I also found this article here:

http://askubuntu.com/questions/483707/14-04-touchpad-is-too-sensitive

The first response also sounds like it might be helpful, but again I'm not really clear on exactly what's up with those commands.

Can anyone help me out with this?

 

EDIT: Anyway to edit the thread title? I meant "TouchPAD issues. . ."


Edited by PrimeMinisterX, 18 July 2016 - 07:50 PM.


BC AdBot (Login to Remove)

 


#2 66Batmobile

66Batmobile

  • Members
  • 323 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:State of Denial
  • Local time:01:55 PM

Posted 18 July 2016 - 07:43 PM

I'm not familiar with Lubuntu, is there anything under Settings or Preferences?...in regular Ubuntu and Mint it's just listed as "mouse and touchpad".


Edited by 66Batmobile, 18 July 2016 - 07:44 PM.

Gen. Barker - You haven't heard the last of this!!

Hawkeye Pierce - I wasn't listening to the first of it...


#3 PrimeMinisterX

PrimeMinisterX
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 18 July 2016 - 07:48 PM

I'm not familiar with Lubuntu, is there anything under Settings or Preferences?...in regular Ubuntu and Mint it's just listed as "mouse and touchpad".

 

Yea, I can go into Keyboard and Mouse and put the sensitivity to the lowest possible setting and it makes no difference.



#4 66Batmobile

66Batmobile

  • Members
  • 323 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:State of Denial
  • Local time:01:55 PM

Posted 18 July 2016 - 07:59 PM

I found this article and the "Disable touchpad while typing" option seems like it might be helpful:

https://help.ubuntu.com/community/Lubuntu/Mouse

But I apparently don't know how to type the commands into the terminal.

The first command should tell you if you already have the synaptics drivers.  No sudo needed, just type in terminal and press enter:

synaptic -l

If it returns something like "Couldn't find synaptics properties. No synaptics driver loaded?" then I think you would need to install them.


Gen. Barker - You haven't heard the last of this!!

Hawkeye Pierce - I wasn't listening to the first of it...


#5 PrimeMinisterX

PrimeMinisterX
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 18 July 2016 - 08:28 PM

synaptic -l

The first command should tell you if you already have the synaptics drivers.  No sudo needed, just type in terminal and press enter:

 

If it returns something like "Couldn't find synaptics properties. No synaptics driver loaded?" then I think you would need to install them.

 

 

When I punch that in I get the following error:

 

E: Command line option 'l' [from -l] is not understood in combination with the other options.
 



#6 66Batmobile

66Batmobile

  • Members
  • 323 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:State of Denial
  • Local time:01:55 PM

Posted 18 July 2016 - 08:38 PM

 

synaptic -l

The first command should tell you if you already have the synaptics drivers.  No sudo needed, just type in terminal and press enter:

 

If it returns something like "Couldn't find synaptics properties. No synaptics driver loaded?" then I think you would need to install them.

 

 

When I punch that in I get the following error:

 

E: Command line option 'l' [from -l] is not understood in combination with the other options.
 

 

Weird...just to cover all the bases, are you typing a lower case "L" for  -l

 

I ask because the terminal is case sensitive, and I've had all sorts of fun confusing stuff like that.


Gen. Barker - You haven't heard the last of this!!

Hawkeye Pierce - I wasn't listening to the first of it...


#7 PrimeMinisterX

PrimeMinisterX
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 18 July 2016 - 09:20 PM

 

Weird...just to cover all the bases, are you typing a lower case "L" for  -l

I ask because the terminal is case sensitive, and I've had all sorts of fun confusing stuff like that.

 

 

 

Yep, lowercase. I also tried it just by copying and pasting directly into the terminal.


Edited by PrimeMinisterX, 18 July 2016 - 09:22 PM.


#8 66Batmobile

66Batmobile

  • Members
  • 323 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:State of Denial
  • Local time:01:55 PM

Posted 18 July 2016 - 09:53 PM

My apologies-that should have been:

 

synclient -l

 

Again no sudo, lower case L

 

Just trying to get you started and see if anything needs to be installed-also if you could list what version of Lubuntu you are running, it will help when the actual "smart" people get here...

 

Very sorry for the mix-up :blush: :unsure:


Gen. Barker - You haven't heard the last of this!!

Hawkeye Pierce - I wasn't listening to the first of it...


#9 PrimeMinisterX

PrimeMinisterX
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 18 July 2016 - 10:22 PM

My apologies-that should have been:

 

synclient -l

 

Again no sudo, lower case L

 

Just trying to get you started and see if anything needs to be installed-also if you could list what version of Lubuntu you are running, it will help when the actual "smart" people get here...

 

Very sorry for the mix-up :blush: :unsure:

 

 

It's all good.

 

I ran synclient -l and it came back with a ton of parameter settings. Stuff like:

 

LeftEdge = 1574

TapButton1 = 1

PalmMinz = 200

etc.

 

And it's Lubuntu 16.04 LTS.



#10 A Future Pilot

A Future Pilot

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:TN, USA
  • Local time:12:55 PM

Posted 19 July 2016 - 09:35 AM

If you run

syndaemon -k -d -i 1

What does it do?

 

Also could you post the complete output of synclient -l please?


Edited by A Future Pilot, 19 July 2016 - 09:40 AM.


#11 pcpunk

pcpunk

  • Members
  • 5,865 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:01:55 PM

Posted 19 July 2016 - 11:07 AM

This should help you out a little

https://help.ubuntu.com/community/SynapticsTouchpad#Introduction


sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#12 pcpunk

pcpunk

  • Members
  • 5,865 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:01:55 PM

Posted 19 July 2016 - 06:32 PM

Run this command to see if it is being detected

 

I am doing this in 14.04 so don't know if it will work for you but will post it anyway.  Don't see anything on that page that says it won't work in 16.04?

xinput list

The important part being:  SynPS/2 Synaptics TouchPad                  id=11    [slave  pointer  (2)]

 

"If one of the lines mentions a touchpad or glidepoint (perhaps also "Synaptics" or "ALPS"), your touchpad has been detected.

If one of the lines mentions an "ADB mouse", then your touchpad is old. Use the trackpad command line tool to configure it. Here's an example to switch on tapping and dragging:"

https://help.ubuntu.com/community/SynapticsTouchpad

 

If it is being Detected as a good Touchpad and not a Generic one than you can follow the directions below this output.

The outcome should look something like this:

 

lubuntu@lubuntu:~$ xinput list
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:4013    id=9    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=11    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=10    [slave  keyboard (3)]
    ↳ Toshiba input device                        id=12    [slave  keyboard (3)]
lubuntu@lubuntu:~$
 

 

This fixed it for me, open the LXTerminal.

 

1. Menu > Accessories > LXTerminal

 

2. Copy Paste below into Terminal and hit enter.  If it asks for Password then type it in and hit Enter.

sudo leafpad ~/.config/lxsession/Lubuntu/autostart 

When Text Editor Leafpad opens, Copy Paste this into it, Save it and close.  Logout and back in to see if it worked.

syndaemon -d -t

If these changes don't work we can get rid of them.


Edited by pcpunk, 19 July 2016 - 06:45 PM.

sBCcBvM.png

Created by Mike_Walsh

 

KDE, Ruler of all Distro's

eps2.4_m4ster-s1ave.aes_pcpunk_leavemehere

 


#13 PrimeMinisterX

PrimeMinisterX
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 23 July 2016 - 07:35 PM

If you run

syndaemon -k -d -i 1

What does it do?

 

Also could you post the complete output of synclient -l please?

 

 

My apologies on the slow response.

 

Running the command you listed didn't seem to do anything. Just returned me to a command prompt.

 

As for synclient -l, I get:

 

Spoiler



#14 PrimeMinisterX

PrimeMinisterX
  • Topic Starter

  • Members
  • 23 posts
  • OFFLINE
  •  
  • Local time:11:55 AM

Posted 23 July 2016 - 08:00 PM

Run this command to see if it is being detected

 

I am doing this in 14.04 so don't know if it will work for you but will post it anyway.  Don't see anything on that page that says it won't work in 16.04?

xinput list

The important part being:  SynPS/2 Synaptics TouchPad                  id=11    [slave  pointer  (2)]

 

"If one of the lines mentions a touchpad or glidepoint (perhaps also "Synaptics" or "ALPS"), your touchpad has been detected.

If one of the lines mentions an "ADB mouse", then your touchpad is old. Use the trackpad command line tool to configure it. Here's an example to switch on tapping and dragging:"

https://help.ubuntu.com/community/SynapticsTouchpad

 

If it is being Detected as a good Touchpad and not a Generic one than you can follow the directions below this output.

The outcome should look something like this:

 

lubuntu@lubuntu:~$ xinput list
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Unifying Device. Wireless PID:4013    id=9    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=11    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=10    [slave  keyboard (3)]
    ↳ Toshiba input device                        id=12    [slave  keyboard (3)]
lubuntu@lubuntu:~$
 

 

This fixed it for me, open the LXTerminal.

 

1. Menu > Accessories > LXTerminal

 

2. Copy Paste below into Terminal and hit enter.  If it asks for Password then type it in and hit Enter.

sudo leafpad ~/.config/lxsession/Lubuntu/autostart 

When Text Editor Leafpad opens, Copy Paste this into it, Save it and close.  Logout and back in to see if it worked.

syndaemon -d -t

If these changes don't work we can get rid of them.

 

 

 

I ran xinput list and got:

 

SynPS/2 Synaptics TouchPad                  id=13    [slave  pointer  (2)]

 

So I went ahead with the rest of your instructions. I'll test it out and let you know what's up.

 

What precisely did we do here?


Edited by PrimeMinisterX, 23 July 2016 - 08:00 PM.


#15 A Future Pilot

A Future Pilot

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:TN, USA
  • Local time:12:55 PM

Posted 23 July 2016 - 08:40 PM

If my command didn't work, I'd be surprised if his did (they're the same command, just his will run every time at boot, whereas mine would simply run when you typed it). If it does though, great!

 

If it doesn't, remove the line you added to ~/.config/lxsession/Lubuntu/autostart, and reboot. You can then try installing tpconfig (sudo apt-get install tpconfig) and running it. Inside it, there is an option to disable touchpad while typing. Try that and see if it works :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users