Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Debconf


  • Please log in to reply
6 replies to this topic

#1 Tamimwm

Tamimwm

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:01:08 AM

Posted 17 July 2016 - 08:32 AM

Good day everyone ,
 
I was updating my linux system today and received a pop up window with debconf at the top  configure secure boot and disable UEFI
 
secure boot, and honestly I haven't got much idea about it any help or suggestions are appreciated.

Edited by Queen-Evie, 17 July 2016 - 09:56 AM.
moved from Linux How-To and Tutorial Section


BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,407 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:09:08 AM

Posted 17 July 2016 - 08:21 PM

What distro are you using? Eg Ubuntu 16.4? Linux Mint 18. The more information you can provide the better we can help you.



#3 Tamimwm

Tamimwm
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:01:08 AM

Posted 18 July 2016 - 02:41 AM

Hey there,

 

I am using linux mint 18.  In a dual boot pc along with win 8.1. If anything else you need to know tell me.



#4 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:08 AM

Posted 18 July 2016 - 03:53 AM

Hi Tamim, it's been 7 months so hopefully you were coasting smoothly during that time.

 

Previously, you were with I think postimg.org for image hosting, is that still so?

 

If you can post any screenshots of what you are experiencing, and provide us with the specs of your computer, that would be helpful.

 

Cheers

 

:wizardball: Wiz

 

Also with LM 18 - MATE, Cinnamon or KDE desktop?

 

Edited typo, added BTW


Edited by wizardfromoz, 18 July 2016 - 03:54 AM.


#5 Tamimwm

Tamimwm
  • Topic Starter

  • Members
  • 181 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cyprus
  • Local time:01:08 AM

Posted 18 July 2016 - 04:30 AM

Well great to see you too wizard. Yes I did use postimg. To be honest I am still as uninformed as I was those 7 months back. I am still facing difficulty, a lot of it while using linux. As such I had depended on windows more than I had planned.

 

Linux Mint 18 cinnamon.

 

Unfortunately I had to turn my pc off and cancel that window. But I looked the issue online and found something similar on the ubuntu forum. I don't knw if this is

appliccable to linux mint as well but it is the same issue as it seems to me .

 

Link : http://askubuntu.com/questions/755238/why-disabling-secure-boot-is-enforced-policy-when-installing-3rd-party-modules

 

 

I can't get a screenshot at the moment but I can tell you that the window had a help button, which says that I have to turn off UEFI in order to install/use some third party drivers. ( As far as  memory works )

 

Anyways I shall sleep on the matter for now.

 

Speccy link :

http://speccy.piriform.com/results/MHHlV1PVWPnYzAqowRUxtuI



#6 wizardfromoz

wizardfromoz

  • Banned
  • 2,799 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:08 AM

Posted 18 July 2016 - 06:47 AM

 

Anyways I shall sleep on the matter for now

 

Ditto .. we'll "talk" tomorrow

 

:wizardball:



#7 A Future Pilot

A Future Pilot

  • Members
  • 78 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:TN, USA
  • Local time:06:08 PM

Posted 19 July 2016 - 09:59 AM

Basically, most modern BIOSs have a feature called "Secure Boot". What it does (in a nutshell) is check what is booting up and verify that it hasn't been modified by malicious code. This is done by signatures created by Canonical (the people who make Ubuntu). The problem is, some third-party drivers need to compile kernel modules themselves, which (because they're being compiled on your computer) can't be signed automatically by Canonical.

 

The easiest way to fix it, is to go into your BIOS (if you're not sure how to do that, I'll need to know what type of computer you have to tell you how), then look through it for a setting called "Secure Boot". Turn it off, and you'll be good to go.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users