Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

IP issue with running a web server


  • Please log in to reply
12 replies to this topic

#1 rjisinspired

rjisinspired

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:09:44 AM

Posted 11 July 2016 - 09:54 AM

I have been using a web server program since 2004. Recently I changed my modem/router due to an error (651) that  I was having with my ISP. This error would creep up from time to time over years but would usually clear up within hours or maybe up to a day but this ended up not being the case this last time around.

 

I started up my web server and updated my DYNDNS host, as I have done for the longest time, and I received a “connection refused” web page when trying to access my DYNDNS address. I am not as sure but it seems to me that the IP that is displaying, that gets assigned, is at the router and doesn’t show up in IPCONFIG and my guess is this would be the problem? I am not able to host my files anymore because of this change. Using the DNS name without the port number gains me access to the config of my router! The 192 address is shown many times in IPCONFIG but the net assigned number is not.

 

This modem/router from my ISP is newer. I never had any issues with running a web server with my other devices but I now cannot use them.

 

If anyone would have any idea as to what I may be talking about and if anyone would know if there is something that needs to be set to make things work again that would be nice. My ISP will not be of any much help with this. I have been with them for over 15 years and it has been a rocky road, to say the very least. I have also sent out a message to the maker of the above web server program and will be waiting for his response as well.

 

Thanks for everyone's time and for any help and support anyone may have.



BC AdBot (Login to Remove)

 


#2 Wand3r3r

Wand3r3r

  • Members
  • 2,027 posts
  • OFFLINE
  •  
  • Local time:06:44 AM

Posted 11 July 2016 - 09:59 AM

" Using the DNS name without the port number gains me access to the config of my router!"

This indicates two things; the dyndns record is updated correctly and you have remote administration via the wan port enabled which is a security issue [unless you like getting hacked]

 

I suspect you never setup port forwarding for your web server in the new router.  do so.



#3 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:08:44 AM

Posted 11 July 2016 - 10:31 AM

On top of port forwarding, don't forget to add DHCP rules/reservations. Even if you forward port 80 to example 192.168.1.2, if the computer with the server on it gets the IP 192.168.1.3 from your router, it won't work. Did you need help setting up port forwarding and DHCP reservation? If so, what model router/gateway do you have?



#4 rjisinspired

rjisinspired
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:09:44 AM

Posted 11 July 2016 - 11:58 AM

The router is an Actiontec GT784WNV. I have always used port 8080 for as long as I had been running the server., 12 years  I never had to adjust anything in a modem/router before , this is a first.

 

Is there an instructional that shows how to set things right?



#5 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:08:44 AM

Posted 11 July 2016 - 12:19 PM

You have been running a web server for 12 years and you never set up port forwarding? :scratchhead:  If that is true, then either there was magic involved, or the gateway was in bridge mode. You wouldn't need to forward anything if the gateway wasn't using NAT. The new gateway probably does, unless you set it to bridge mode. Does more then 1 computer (other then server) need to get online at a time? What IP does the web server get?


Edited by Trikein, 11 July 2016 - 12:20 PM.


#6 rjisinspired

rjisinspired
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:09:44 AM

Posted 11 July 2016 - 12:33 PM

Nope  never had to set that. Just set 8080 on the server and that was it.  The web server gets the Net IP address and I use the DNS name to access web site, files, etc.

 

There are no other computers involved. Just one computer running a server.. Regular use computer running NAWS server.

 

There is a bridge setting in this newer router and it states that once set it that you can't set it back? The other modems/routers I have set up before using this newer one, there was an option to bridge the connections but I never did. I honestly don't know..  From what I am getting I need to forward or make the assigned IP reflect what I should be using. if there is an instructional on how to do this that would be great. At this point I have no clue as to what I should be doing. Thanks for taking the time and responding.



#7 rjisinspired

rjisinspired
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:09:44 AM

Posted 11 July 2016 - 12:38 PM

I am noticing that my assigned net IP is changing frequently after I keep updating my DNS name at dyndns???  I am lost.



#8 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:08:44 AM

Posted 11 July 2016 - 12:51 PM

I think you are missing a understanding of how routers work. The router will get a public (68.1.2.3) IP from it's WAN port and use NAT to route that IP to the public (192.168.1.2)IPs the DHCP server in the router hands out. If it doesn't do this, it's not routing, and there for not considered a router. Thats what putting it into bridge mode does; turns that off. If you have a web server on 192.168.1.3, and someone is trying to get to your server at 68.1.2.3:8080, the request goes to the WAN port on your router, and your router needs to know what computer uses that port. Otherwise it would like a business not knowing what phone exstention belongs to who, and trying to call them up and ask for "Bob". No one would know which phone was bobs. However if Bob had a direct line, he wouldn't need a exstention. Make sense?


Edited by Trikein, 11 July 2016 - 12:53 PM.


#9 rjisinspired

rjisinspired
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:09:44 AM

Posted 11 July 2016 - 01:20 PM

I guess what I am looking for is to know how to apply the gateway IP so that it can be used again?. That is what is needed to connect the dns name to.

 

If it seems like I am clueless, I partially am. I am in need with getting things working again quickly. I never had to think about it or heavily read into this stuff. Are there instructions on how to configure/reconfigure the router or on my computer to get things back to where they were?

 

For example my gateway IP is 72.79.x.x 


Edited by rjisinspired, 11 July 2016 - 01:23 PM.


#10 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:08:44 AM

Posted 11 July 2016 - 02:44 PM

"Are there instructions on how to configure/reconfigure the router or on my computer to get things back to where they were?"

 

I can't say exactly how to get it back to the way it was without knowing how it was set up before. I can guess, and that guess is it was in bridge mode. I couldn't find the user manual for the Actiontec GT784WNV, but I did find this Verizon post with instructions below. I would suggest to also disable the wireless, since it will no longer work. Finally, see the linked post for further instructions if you have Verizon DSL.

 

To bridge your router, do the following:

 

Visit http://192.168.1.1/ . You will be prompted for a username and password. Try the following if you have not changed the password:

 

admin/password

admin/admin

admin/admin1

admin/password1

admin/verizon

admin/verizon1

 

Once in the modem, click on "Advanced Setup" in the navigation. In the left hand side navigation, click on "WAN IP Settings." From here, click on the option for RFC 1483 Transparent Bridging and then leave all other settings to their defaults. Click Save.


Edited by Trikein, 11 July 2016 - 02:48 PM.


#11 rjisinspired

rjisinspired
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:09:44 AM

Posted 11 July 2016 - 03:09 PM

Oh WOW! Thank you so much!!!  That did it! Thanks Trikein for your help and time. :bananas:



#12 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:08:44 AM

Posted 11 July 2016 - 03:50 PM

No problem.  :bounce: I would like to caution that this configuration leaves the server "naked in the wind" unless some kind of firewall is set up on the server. I only know Linux, but for basic SPI, try iptaples, for more advanced try PFsense


Edited by Trikein, 11 July 2016 - 06:26 PM.


#13 chrisjohnsonmar

chrisjohnsonmar

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:06:44 PM

Posted 21 July 2016 - 08:33 AM

you can consider a vpn for this, i guess it would give you help if you order vpn from the vpn providers like purevpn, expresso vpn, ivacy vpn etc.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users