Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Black screen if monitor off AFK


  • Please log in to reply
5 replies to this topic

#1 Trikein

Trikein

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:01:31 PM

Posted 06 July 2016 - 10:03 PM

I have a problem that when ever I step away from my computer, I turn off the monitor to conserve power and heat. When I come back and turn the monitor back on, I will sometimes have a black screen. Turning the monitor on/off does nothing, but unplugging the HDMI and plugging it back in instantly solves the problem. This made me think it was HDMI issue but if I force a reboot at the black screen, I get the "Windows is shutting down" before shutting down, making me think it's a driver issue. I have replaced the HDMI and waiting for the issue to return, but anyone else have any other ideas? 

 

Hardware:

 

Asus P7P55D Premium Mobo

Asus HD7950 GPU

Asus VW266H Monitor (set @ 1920x1200)

 

Software:

Windows 7 64bit

Radeon 16.6.1 (same with 3 previous versions)

16.200.1025.0 Display driver

 



BC AdBot (Login to Remove)

 


#2 DavisMcCarn

DavisMcCarn

  • Members
  • 978 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:31 PM

Posted 07 July 2016 - 11:07 AM

Yeah; quit turning the monitor off! When you do that, the PC knows its not there anymore and, especially if the PC then turns off the display, Windoze loses how to turn it back on again.

Instead, get PSShutdown from sysinternals and create a shortcut to a BAT file with psshutdown.exe -d -t 0 -accepteula<enter> in it. Double clicking that shortcut will then put the computer to sleep and it will be right where you left it when you wake it up.
https://technet.microsoft.com/en-us/sysinternals/psshutdown.aspx
Computer dinosaur, servicing PC's since 1976

#3 Trikein

Trikein
  • Topic Starter

  • Members
  • 1,321 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rhode Island, US
  • Local time:01:31 PM

Posted 07 July 2016 - 01:09 PM

I am looking for another solution other then not turning the monitor off. Many times the computer is still processing and I can't put it into sleep. How does window "lose" the ability to turn it back on?

 

Also, I should note I have another similar problem which started around the same time. Randomly (1 a day?)my sound will stop and turning the monitor on/off does fix the problem, so this isn't a issue not turning off the monitor will completely fix. I almost wounder if it's a sound problem instead of a HDMI issue and HDCP is failing on the sound handshake? Is there anyway to check this? ::edit:: The losing audio problem happened again today after replacing the HDMI last night. 


Edited by Trikein, 07 July 2016 - 03:27 PM.


#4 DavisMcCarn

DavisMcCarn

  • Members
  • 978 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:31 PM

Posted 08 July 2016 - 06:28 AM

Windows queries the hardware several times per minute so, when you turn the monitor off, it knows that within a few seconds.  I think the move to laptops and the major issues that used to happen if someone connected an external monitor is a big part of what drove the change in querying the display(s).

Change the time to turn off the display then, rather than putting it to sleep.

As for the sound, did you disable the onboard sound in the ASUS BIOS?  Many of the onboard sound chips conflict with the one on the GPU.


Computer dinosaur, servicing PC's since 1976

#5 Captain_Chicken

Captain_Chicken

  • BC Advisor
  • 1,369 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:31 PM

Posted 08 July 2016 - 08:46 PM

Go into your monitor settings by pressing the monitor buttons. Go to source and select auto select.

Computer Collection:

Spoiler

Spoiler

Spoiler

Spoiler

#6 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,218 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:31 PM

Posted 10 July 2016 - 06:12 PM

I too am running 64 bit Win 7. Why not just go into 'Control panel - Power options' and change the plan settings and have the computer turn the monitor off ?  You can select a delay period of anything from 1 minute to 'Never'. Then press a key or waggle the mouse to bring the monitor up again when you come back to it. I use 20 minutes as my setting but you might well want one nearer the 1 minute mark.

 

Chris Cosgrove






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users