Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Libraries problem


  • Please log in to reply
10 replies to this topic

#1 Protopia

Protopia

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 23 June 2016 - 01:40 PM

If I enable the Libraries node in File Explorer, nothing happens. If I try to add a director to a Library, the list of libraries is not populated.
 
But if I go and find the libraries in \Users\%userid%\AppData\Roaming\Microsoft\Windows\Libraries they are working and I can change their properties.
 
System is a fresh clean Win 10 64-bit install.
 
I have previously had to clean up using DISM after an SFC /scannow didn't run cleanly, but I have no idea of what the cuase is or how to fix it.
 
O if anyone else has any ideas, please let me know.

Edited by Queen-Evie, 23 June 2016 - 03:00 PM.
moved from Windows 10 Discussion to Windows 10 Support


BC AdBot (Login to Remove)

 


#2 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:07:12 PM

Posted 24 June 2016 - 09:09 PM

  1. In Windows 10, open a new File Explorer window and click the View tab from the ribbon toolbar.
  2. In the View tab, find and click on Options, listed by default on the far right side of the ribbon.
  3. In the Folder Options window, click View tab.
  4. Place a check mark in Show all folders and Show libraries check boxes and click Apply and OK buttons.

Posted Image


#3 Protopia

Protopia
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 25 June 2016 - 02:54 AM

@FreeBooter - I know about that and it doesn't work - ditto for right clicking in the navigation pane and selecting the same.

 

I suspect that some DLLs have become unregistered. But no idea which ones.

 

I am currently thinking of running Win 10 update (against current Win 10) to reset all such registrations. But this seems like a big step to take for a relatively minor problem.



#4 cmptrgy

cmptrgy

  • Members
  • 1,719 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:11:12 AM

Posted 25 June 2016 - 07:25 AM

Go down to Libraries Documents: if it isn't expanded, expand it

You should then have 2 sub Documents

Check the properties on the first sub Documents

--- The location should read C:\Users\"your user name"\OneDrive

Check the properties on the second sub Documents

--- The location should read C:\Users\"your user name"

The idea is to determine whether or not it's set up as a Temp user instead as "your user name"

--- If it isn't set up in "your user name" let us know: I'll dig up my notes on how I had to fix that on my brothers computer a couple of months ago.



#5 Protopia

Protopia
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 25 June 2016 - 10:06 AM

Dear cmptrgy

 

If you had read my original post you would have seen that there is no "Library Documents" node to expand. That is the issue. I need to get the Libraries node to display in the navigation area.

 

But thanks for your idea anyway.

 

P



#6 cmptrgy

cmptrgy

  • Members
  • 1,719 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:11:12 AM

Posted 25 June 2016 - 04:17 PM

Protopia, please I have read your 3 posts and I'm trying to be helpful and this is not an "anyway" answer.

 

In post 1 "If I enable the Libraries node in File Explorer, nothing happens. If I try to add a director to a Library, the list of libraries is not populated." To me that that means the Libraries node in File Explorer is enabled but nothing happens as opposed to it isn't there.

 

In post 3 you mentioned "@FreeBooter - I know about that and it doesn't work - ditto for right clicking in the navigation pane and selecting the same."

--- I interpreted that post to mean that it doesn't work as opposed to it isn't there.

So maybe I need to interpret what I thought better than I did but I cannot see your computer

 

So now in post 5, you say that "That is the issue. I need to get the Libraries node to display in the navigation area."

--- I've done some research on Cannot unhide the data libraries in Windows 10.

--- Not much yet but as you said, the Libraries folder doesn't display in the navigation area is the issue.

 

Please verify

When you click on View, then on Navigation Pane: do both Navigation pane and Show libraries have checkmarks? 



#7 Protopia

Protopia
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 25 June 2016 - 04:42 PM

Yes - both Navigation Pane and Show Libraries are checked.

 

Show All Folders makes no difference whether checked or not - the Libraries node is not displayed in either case.



#8 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:07:12 PM

Posted 26 June 2016 - 12:09 PM

To restore Libraries in the navigation pane, you will need to go to the following location in the Registry:

 


Registry File
HKEY_CLASSES_ROOT\CLSID\{031E4825-7B94-4dc3-B131-E946B44C8DD5}\ShellFolder

 

 

 

Right-click on the key above, and if necessary change the permission to allow you to edit it.

 

 

Change the Attributes value back to b080010d.


Posted Image


#9 Protopia

Protopia
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:12 PM

Posted 26 June 2016 - 12:24 PM

Nope - already researched the internet and checked that egistry entry.

 

This afternoon I did a Win 10 upgrade on the existing Win 10 and (after a couple of false starts) this fixed it.

 

So thanks to everyone who tried to help.



#10 FreeBooter

FreeBooter

  • Members
  • 3,137 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Turkey - Adana
  • Local time:07:12 PM

Posted 26 June 2016 - 12:37 PM

You are very welcome, glad to know issue has been resolved!


Posted Image


#11 cmptrgy

cmptrgy

  • Members
  • 1,719 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Massachusetts
  • Local time:11:12 AM

Posted 26 June 2016 - 12:52 PM

Thanks Protopia, it's always good to hear good news






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users