Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Suspected SMM rootkit modificiation on several machines, all Intel


  • Please log in to reply
No replies to this topic

#1 MagicTux

MagicTux

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Local time:02:53 PM

Posted 11 June 2016 - 03:56 PM

Hey guys 

I'm posting here cause I'm really desperate. I have been suffering with some rootkit for some month now and I'm suspecting a SMM rootkit.
I have previously received help here on the Virus, Trojan, Spyware, and Malware Removal Logs section in two threads.

#1: (http://www.bleepingcomputer.com/forums/t/611270/bios-infection-possible-virus-rootkit/)
#2: (http://www.bleepingcomputer.com/forums/t/612925/rootkit-infection-by-usb-drive-windows-update-acts-weird-fake-antivirus/)
 
Two Malware Response Instructors who first examined my FRST logs, couldn't find evidence of active malware on my computer.

The first build had MSI G45 Gaming Z87 motherboard and got infected. I ended up buying a Gigabyte Z97X Gaming 3 and got infected again by mistake.
 
I have tried Windows 7 x64, Windows 8.1 x64 and Windows 10 pro x64 all bought and legit, but it still seems like my OS is being fiddle with.

When I bought the Gigabyte motherboard I reused all same hardware such as CPU, GFX, HDD, SSD, RAM and DVD-drive and were clean until I made a mistake with the wrong USB-drive.

I'm quite convinced that something has been messed with on the motherboard and I have looked into chipsec (http://www.intelsecurity.com/advanced-threat-research/chipsec.html)

I have tried to fuzz SMM and found a bad SMI handler, but I'm clueless how to fix it. Here is a screenshot taken from chipsec (http://imgur.com/4PFHIcn)

Best regards,
Morten


Edited by MagicTux, 11 June 2016 - 04:04 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users