Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Multiple network issues


  • Please log in to reply
1 reply to this topic

#1 atantot

atantot

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:44 AM

Posted 01 June 2016 - 06:16 AM

Hello,

 

on one of my computer running Windows 7, I got multiple errors during the last days.

 

The browser is working fine on the computer, I can go to whatever website I want. The computer gets an IP (I can see it with ipconfig/all or on websites such as whatismyip...). 

 

I used to be able to ping this computer from other computers on the same network (on the same switch) but for some reasons, I only get "request time out" when I try now.

 

When I try to use the ping command on the computer (ping google.com  or ping localhost or ping whateverIPaddress), I get the following error:

"Ping transmit failed. General failure".

 

If I try to run a diagnostic on the network adapter, I get the error:

"The Diagnostic Policy Service is not running".

 

I tried to start the Diagnostic Policy Service through Local services, I get "Error 5: Access denied".

 

To fix the last error, I tried the following commands in a command prompt (using administrator privileges):

net localgroup Administrators /add networkservice

net localgroup Administrators /add localservice

net localgroup Administrators NAME /add    (NAME is the actual user name)

In all cases, I got:

"System error 1378 has occured. The specified account name is already a member of the group".

 

I tried to reinstall the network card multiple times and to reboot the computer without success (though the device manager).

 

I also tried to run sfc /scannow

It detected two errors ("utc.app.json" and "telemetry.ASM-WindowsDefault.json"). I fixed them using SFCFix. I run a new scan and everything was fine. That didn't fix the network issue.

 

I tried a tracert google.com on the computer and compared it to the results got on another computer. Both paths were similar.

 

I ran a scan with Avast and Malwarebytes but they didn't find anything (and they are up-to-date).

 

For some reasons, I can connect to the computer with Teamviewer using the ID and the password. However, the computer is not automatically detected in my Teamviewer account (it used to be). Other computers on the same network are detected fine.

 

I don't know what can be my next move...

 

Thank you in advance.

 

A.


Edited by atantot, 01 June 2016 - 01:00 PM.


BC AdBot (Login to Remove)

 


#2 atantot

atantot
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:44 AM

Posted 02 June 2016 - 05:21 AM

The ping command seems to work fine if I run the command prompt as an administrator. Does that help ?

 

The Firewall is off for some reasons. When I try to turn it on, I get the error 0x8007042c. Moreover, using Process monitor, I can see two access denied for:

HKLM\System\CurrentControlSet\Services\BFE\Parameters\Policy\Persistent when I try to turn on the firewall.

 

When I try to run a network diagnosis, I get two access denied for:

HKLM\System\CurrentControlSet\Control\WDI\Config

 

EDIT:

in order to fix the permission issue during the network diagnosis, I applied this protocol (https://social.technet.microsoft.com/Forums/windows/en-US/366756ad-a2e4-4b57-bbc9-258d42b00796/diagnostic-policy-service?forum=itprovistanetworking) to:

HKLM\System\CurrentControlSet\Control\WDI\Config

HKLM\System\CurrentControlSet\Control\MemoryDiagnostic

 

I can do a diagnosis but it does not detect anything wrong... and Process monitor gives me other access denied:

HKLM\System\CurrentControlSet\Services\WinSock2\Parameters

 

I do not get what happened on this computer (it is not part of a domain by the way)...

 

Thank you in advance,

 

A.


Edited by atantot, 02 June 2016 - 06:24 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users