Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dell Latitude E6430: Screen goes white when power unplugged


  • Please log in to reply
No replies to this topic

#1 danjek929

danjek929

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:04 AM

Posted 29 May 2016 - 10:08 PM

Hi there. I've been having this very odd problem with my Dell Latitude E6430: Whenever I unplug the power cord from the computer, the display just turns white, blank. But when I plug it back in, the display goes back to normal. Before this, though, my screen was white even when the power cord was plugged in; however, I "fixed" it by unplugging/plugging back in the LCD cable on the display, which led to this issue. What could be the problem here? I've opened up the laptop and unplugged/plugged in the DC jack on the motherboard to see if that was the case, but that didn't do anything. Anything else I could do? Thanks a lot.

 

EDIT: The computer works fine with an external display, no hiccups with/without the power plugged in. Also, for some strange reason, after plugging in the HDMI cable for the display, then unplugging the power cord and then the HDMI, the display works without power cord for a bit before flickering back to white.


Edited by danjek929, 29 May 2016 - 10:17 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users