Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internal webcam


  • Please log in to reply
18 replies to this topic

#1 ray5450

ray5450

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 25 May 2016 - 03:56 PM

Here is my information:

Internal camera:  Sony Visual Communications Camera VGP-VCC2

OS:  32 bit XP (complete OS/not from Sony)

 

Factuals:

1.  On the Sony website, I find a driver for this webcam, but no software for it, so I downloaded and tried several.  The one that looks like the one I want is Free2x,  but all of them give no image (black). 

 

2.  The green light on the camera is blinking. 

 

3.  The driver shows as installed in Device Manager.

 

Any way to make it work?

 

Thanks.

 

 

 



BC AdBot (Login to Remove)

 


#2 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 25 May 2016 - 04:43 PM

Hi,

 

I usually use this website to test the webcam http://www.testwebcam.com/ if the proper driver is installed it will show the image captured by the camera.

 

You have to allow flash to use the webcam during the test.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#3 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 26 May 2016 - 09:12 PM

Okay, thanks.

 

Again, the webcam light was flashing, but the square, where I assume the image should be, is black.



#4 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 27 May 2016 - 03:39 PM

Hi,

 

Again, the webcam light was flashing, but the square, where I assume the image should be, is black.

 

Did you check if by any change something is covering the webcam lens?


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#5 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 31 May 2016 - 07:18 PM

It is built into the top of the monitor.  It looks the same as any other that I have seen.  This one has a 4 layer bullseye type appearance:  a white ring outside of a black area, which surrounds a gray area, which surrounds a small pinhole lens, all the foregoing having a protective, clear (and clean), plastic layer.


Edited by ray5450, 31 May 2016 - 07:18 PM.


#6 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 01 June 2016 - 03:14 AM

I'm not sure if the black image can be a result of a wrong driver!

 

Can you post the Device ID of the webcam?

 

 

  • Open Device Manager (Start > Run > devmgmt.msc)
  • right click the webcam
  • click Properties > Tab Details > On the Property box select Device Instance Id
  • Copy & Paste the values on the box to your Reply

 

 


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#7 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 02 June 2016 - 02:22 PM

USB\VID_05CA&PID_1830\5&C1E6CCE&0&1

Here are the driver and version under driver Properties:

Sony Visual Communication Camera VGP-VCC2
Microvision
12/28/2005
1.0.2.9



#8 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 02 June 2016 - 03:05 PM

What is the exact model of the machine? VGN-????


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#9 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 02 June 2016 - 05:44 PM

VGN-SZ340



#10 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 03 June 2016 - 03:37 AM

Hi,

 

Did you try with the driver available here?


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#11 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 08 June 2016 - 06:02 PM

I'm not sure.  The version is the same, but the date is different.  When I tried to intall it anyway, Windows says, "This update is not intended for use with your computer model", but I know that most of the time it says that if the same driver is already installed.

I tried to uninstall the current driver to install the one you suggest just in case, but it only deletes the device off the list and not the driver, and when it reboots, it just finds the device, and adds it back with the same driver.



#12 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 09 June 2016 - 03:59 AM

Try this one instead, access http://www.sony-asia.com/support/download/58144 download and install CAM-0603SZ31-ENG


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#13 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 13 June 2016 - 10:52 PM

With CAM-0603SZ31-ENG.EXE, Windows also says,"This update is not intended for use with your computer model".



#14 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,125 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:07:41 PM

Posted 14 June 2016 - 03:08 PM

With CAM-0603SZ31-ENG.EXE, Windows also says,"This update is not intended for use with your computer model".

 

Strange because the driver matches the Hardware ID!

 

I have extracted the driver please download the CAM-0603SZ31-ENG.zip and extract the file to some folder for example C:\Drivers\Webcam

Open the Device Manager, right click on the webcam and select Update Driver, choose the option to search for the driver on the folder C:\Drivers\Webcam


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#15 ray5450

ray5450
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:41 PM

Posted 15 June 2016 - 10:56 PM

Hardware Update Wizard says, "The wizard could not find a better match for your hardware than the software you currently have installed."






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users