Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

300 GB drive wont mount at startup


  • Please log in to reply
13 replies to this topic

#1 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W


  • Members
  • 5,709 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 18 May 2016 - 11:05 PM

Linux Mint 17.3

 

3 hard drives

 

SSD....this is the 'boot' drive contains linux mint plus a little bit of music

 

250gb hdd....this is used for backup...nothing else

 

300gb hdd....tjhis contains data movies, blah blah

 

In "disks" I have the 300gb set to 'mount at startup'

 

It does not happen.

 

 

 

1442ngz.jpg


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

 

 

 

 

 


BC AdBot (Login to Remove)

 


#2 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:10 AM

Posted 19 May 2016 - 02:53 AM

Please post the output of these commands:
 
sudo blkid
cat /etc/fstab


#3 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,709 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 19 May 2016 - 03:21 AM

I have bolded the 300gb drive

 

Also....the 5th line up from the bottom shows 5F4654761E51863F  .....I think (not totally sure) these figures refer to the same drive.

 

brian@brian-EX58-UD3R ~ $ sudo blkid
[sudo] password for brian:
/dev/sda1: LABEL="backup" UUID="1f108175-3dcc-4ee0-b7f1-89106f3ee47b" TYPE="ext4"
/dev/sdb1: UUID="7b8b330e-b38e-4e5c-9d2c-d6a5ba691e5a" TYPE="ext4"
/dev/sdc1: UUID="cf4ec0c4-38e3-464e-84d2-b0bd56b4e1e0" TYPE="ext4"
brian@brian-EX58-UD3R ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb1 during installation
# swap was on /dev/sda6 during installation
#UUID=839d9105-e4bf-4e2e-ba1a-69b96459e440 none            swap    sw              0       0
#/dev/disk/by-uuid/5F4654761E51863F /mnt/5F4654761E51863F auto nosuid,nodev,nofail,x-gvfs-show 0 0
# a swapfile is not a swap partition, no line here
#   use  dphys-swapfile swap[on|off]  for that
#UUID=839d9105-e4bf-4e2e-ba1a-69b96459e440 /               ext4    noatime,errors=remount-ro 0       0
brian@brian-EX58-UD3R ~ $


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

 

 

 

 

 


#4 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:10 AM

Posted 19 May 2016 - 03:49 AM

It's strange that all of the lines are commented out. I've never seen that before. In any case, adding a line for your 300GiB to fstab should do the trick. First of all make a back up of fstab by running this command:
sudo cp /etc/fstab /etc/fstab.old
Then open /etc/fstab in a text editor, and type or copy and paste the following line:
UUID=cf4ec0c4-38e3-464e-84d2-b0bd56b4e1e0 /data ext4 defaults 0 2
The file should now look like this:


# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sdb1 during installation
# swap was on /dev/sda6 during installation
#UUID=839d9105-e4bf-4e2e-ba1a-69b96459e440 none swap sw 0 0
#/dev/disk/by-uuid/5F4654761E51863F /mnt/5F4654761E51863F auto nosuid,nodev,nofail,x-gvfs-show 0 0
# a swapfile is not a swap partition, no line here
# use dphys-swapfile swap[on|off] for that
#UUID=839d9105-e4bf-4e2e-ba1a-69b96459e440 / ext4 noatime,errors=remount-ro 0 0
UUID=cf4ec0c4-38e3-464e-84d2-b0bd56b4e1e0 /data ext4 defaults 0 2


Save and exit the text editor, reboot your computer, and the partition should be mounted.

Edited by Al1000, 19 May 2016 - 03:54 AM.


#5 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,709 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 19 May 2016 - 04:34 AM

I edited fstab and included the line....saved...rebooted.

 

The 300gb failed to mount with the restart, and said 'unable to mount when i double clicked it in 'computer'

 

I opened 'disks'...clicked on  the 300gb ....then on more actions and edit mount options.......automatic mount options was set to "off"

 

I switched it to "on"....rebooted......still did not mount.

 

However....when I double clicked on the drive in 'computer' it produced this error :

 

Error mounting system-managed device /dev/sdc1: Command-line `mount "/mnt/cf4ec0c4-38e3-464e-84d2-b0bd56b4e1e0"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

 

Edit: the other hdd (backup) mounts when I double click in 'computer'


Edited by Condobloke, 19 May 2016 - 04:53 AM.

Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

 

 

 

 

 


#6 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:10 AM

Posted 19 May 2016 - 05:43 AM

That's odd, Did the 300GiB drive mount ok beforehand when you clicked on it in "computer"?

If so then I would replace /etc/fstab with the original file by running this command:
sudo cp /etc/fstab.old /etc/fstab
Then reboot the computer and check you can still mount it by clicking on it.

#7 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,709 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 19 May 2016 - 05:48 AM

Yes...mounted by double clicking

 

 

edit...when i lookin disks again....the automatic mount options is set to 'on'

....and yes it did mount before by the double click method


Edited by Condobloke, 19 May 2016 - 05:59 AM.

Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

 

 

 

 

 


#8 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:10 AM

Posted 19 May 2016 - 06:17 AM

I've never used these "automatic mount options."

There may be some option which has to be used for SSDs that I'm not aware of. I would hang on and hopefully someone with an SSD can advise.

Sorry I can't be of more help just now.

PS: if you have a directory called /data (which you should see if you click on "computer") you can delete it by running this command. I recommend unmounting the 300GiB drive before running the command, just on the off-chance it's mounted there.
sudo rm -r /data

Edited by Al1000, 19 May 2016 - 06:19 AM.


#9 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,407 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:09:10 AM

Posted 19 May 2016 - 06:37 AM

Have a read of this Starting at No 8 its the second post.

http://askubuntu.com/questions/154180/how-to-mount-a-new-drive-on-startup


Edited by NickAu, 19 May 2016 - 06:53 AM.


#10 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,709 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 19 May 2016 - 06:57 AM

N.........you have done it again.

 

mission accomplished.

 

Thanks mate

 

B


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

 

 

 

 

 


#11 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:10 AM

Posted 19 May 2016 - 06:57 AM

EDIT:

Is this the one that works? (replacing "X" with "1")
 
/dev/sdaX /media/mydata ext4 defaults 0 0

Edited by Al1000, 19 May 2016 - 07:01 AM.


#12 Condobloke

Condobloke

    Outback Aussie @ 54.2101 N, 0.2906 W

  • Topic Starter

  • Members
  • 5,709 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:10 AM

Posted 19 May 2016 - 07:01 AM

This was the fix...

 

 

To set the drive to mount automatically each time you boot the computer

You’ll need to edit /etc/fstab:

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

gksudo gedit /etc/fstab

Add this line to the end:

/dev/sdaX /media/mydata ext4 defaults 0 0

Note: Make sure to replace the X with the right value for your situation......which in my case was   sdc1

 

 

I actually saw that page a few days ago but becasue it had some large print saying.....WARNING THIS WILL DESTROY ANY DATA ON YOUR TARGET DISK....so I skipped the page and read elsewhere !!

 

 

 

 

Thanks both of you guys for putting in the effort !!

 

 

 

 

 

 

 

 

 

 

 

 


Condobloke ...Outback Australian  

 

fed up with Windows antics...??....LINUX IS THE ANSWER....I USE LINUX MINT 18.3  EXCLUSIVELY.

 

Microsoft gives you Windows, Linux gives you the whole house...

 

 

 

 

 


#13 Al1000

Al1000

  • Global Moderator
  • 7,187 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:10 AM

Posted 19 May 2016 - 07:06 AM

Glad you got it sorted!

The SSD will now mount in a directory called /media/mydata

If you want to mount it somewhere else, for example /media/yourusername/SSD, just edit the mount point in fstab again.

Personally I would also change /dev/sdc1 for UUID=cf4ec0c4-38e3-464e-84d2-b0bd56b4e1e0 so that it will still mount if you change the drives around, which is the recommended way of doing it, but the way you've done it will work just as well so long as you keep the same drives.

Edited by Al1000, 19 May 2016 - 07:12 AM.


#14 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,407 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:09:10 AM

Posted 19 May 2016 - 07:11 AM

You are welcome.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users