Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ghost file opening on startup


  • Please log in to reply
3 replies to this topic

#1 Campo1988

Campo1988

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:10:04 AM

Posted 18 May 2016 - 01:57 PM

Hi.

I was using a programme recently, but I can't remember which one, and for whatever reason it decided to stop working properly and created a report to send to its developers. I decided to check what the report contained but never intended to send it. The file was saved as a .tmp file with text in it. I closed the programme and removed the temp file (and others, during cleaning) and it looked as if it wasn't there anymore. However, the very same file opens during startup. I have done a windose search for the file name and file extension but it doesn't exist anywhere, yet it still starts during startup. How can a non-file open during startup? How can I stop it from happening?

Thanks.



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:11:04 AM

Posted 18 May 2016 - 05:44 PM

Three possibilities that I can think of. It is just possible that the program also saved this information as a text file - try searching for 'filename.TXT'.

 

You say the program stopped working properly - have you tried uninstalling it and re-installing it ?  I appreciate this may cause some head scratching as you cannot remember what it was, but worth a look at 'Control panel - Programs and features' to see if anything jogs your memory.

 

You can try stopping it running at start-up by using Msconfig. Type 'msconfig' in search (without the ' ') and right click on 'msconfig.exe' and run as administrator and see if this file shows in the list of applications running at start-up. If it is there, set it to either 'Manual' or 'Disable'. If you have Ccleaner installed you can do the same thing with that. Start it running, select 'Tools' and then 'Start-up'.

 

Chris Cosgrove



#3 Campo1988

Campo1988
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:10:04 AM

Posted 19 May 2016 - 04:03 PM

I always show file extensions. I should have mentioned that. It is opening in Notepad because some tmp files do, and txt, log, and other extensions do. It is definitely .tmp, not .txt.

No, I didn't uninstall then reinstall the programme. It fixed itself, as happens sometimes.

I did check the Starup folder but I didn't check msconfig (which I do know about but forgot!). I'll try that.

...

msconfig told me to use the Start-up tab in Task Manager. Tut. Well, in there, there is the file. I don't know where it is saved because the search didn't show anything - and I have hidden files and folders, and also OS system files, all showing, as well.

Ignore that - it is in the Temp folder. I forgot that sometimes the clever [expletive deleted]s in micros... decide to be so clever and rename files with a ~ at the beginning, for only the reason of making you so, very angry and to make you further neurotic!

I have deleted the file and also disabled it in Task Manager>Start-up.

I'll reboot later and then see if it has worked; if I don't reply, then you'll know it has!

Thanks for your help.



#4 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,875 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:11:04 AM

Posted 19 May 2016 - 05:05 PM

These little things !

 

I am familiar with the use of the '~' symbol in MS Office when an open file generates a temporary copy which (normally) disappears when you close it but I had forgotten that it can crop up in other areas as well, thanks for the reminder - and the explanation of what appears to have been the problem !

 

Feel free to post back it it wasn't the explanation.

 

Chris Cosgrove






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users