Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WD My Book drives not working


  • Please log in to reply
3 replies to this topic

#1 sloventhal

sloventhal

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:44 AM

Posted 17 May 2016 - 01:47 PM

I keep getting unknown USB device  (device descriptor request failed)  code 43.  I have two 3.0 drives and both get the same error.  They work fine on other machines.  Any ideas.  I have tried to delete usb device and then reboot and try again but now luck.  One is a WD My Book 4Tdrive and the other a 5T drive also a WD My Book.  Of course, this is where my backup and other important things are.  Thanks in advance for help



BC AdBot (Login to Remove)

 


#2 usasma

usasma

    Still visually handicapped (avatar is memory developed by my Dad


  • BSOD Kernel Dump Expert
  • 25,091 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Southeastern CT, USA
  • Local time:10:44 AM

Posted 17 May 2016 - 02:03 PM

If they work fine on other systems - then it's most likely this system that's the problem.

What are the system specs?

Have you tried different USB ports?
- front vs back on a Desktop

- right vs left side on a Laptop

Have you updated your chipset and controller drivers from the manufacturer's website?


My browser caused a flood of traffic, sio my IP address was banned. Hope to fix it soon. Will get back to posting as soon as Im able.

- John  (my website: http://www.carrona.org/ )**If you need a more detailed explanation, please ask for it. I have the Knack. **  If I haven't replied in 48 hours, please send me a message. My eye problems have recently increased and I'm having difficult reading posts. (23 Nov 2017)FYI - I am completely blind in the right eye and ~30% blind in the left eye.<p>If the eye problems get worse suddenly, I may not be able to respond.If that's the case and help is needed, please PM a staff member for assistance.

#3 sloventhal

sloventhal
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:44 AM

Posted 17 May 2016 - 06:21 PM

HP Intel i5-6400 CPU 2.7GHz  12Gb memory

64-bit Windows 10 Home

 

Machine only a couple of months old so I haven't tried updating chipset or controller drivers but windows says USB drivers are current.

 

Have tried both back and front ports since it is a desktop

 

will check on the chipset, etc tomorrow.  Originally at least one of them did work on this new machine.



#4 kbp80

kbp80

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sydney, NSW, Australia
  • Local time:12:44 AM

Posted 18 May 2016 - 07:13 PM

Hi sloventhal,

 

I would highly recommend updating your USB 3.0 controller drivers. In past experience these drivers are usually the culprit. Seeing as this issue effects more than one HDD it appears that it's a PC issue rather than a problem with your HDDs (unless you are incredibly unlucky).






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users