Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Runtime Error - atibtmon.exe


  • Please log in to reply
7 replies to this topic

#1 ndonaldson2912

ndonaldson2912

  • Members
  • 234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:15 PM

Posted 13 May 2016 - 07:35 AM

Hi all, 

 

I see this is a common problem but I have not been able to resolve mine...

 

Acer Aspire 555-A laptop.

Win10 - 64bit

 

Whenever my laptop is switched on without power cord, or i disconnect power cord whenever i am using it, I get this message;

 

ProgramC:\WINDOWS\System32\ATIBTMON-exe saying that this applications has requested the runtime to terminate in an unusual way.

 

My integrated display adapter is: ATI Mobility raedon HD 4200 series and the driver version is: 8.970.100.9001

When I go to update the driver it says I have the most up-to-date version.

 

I see that it is recommended to go into catalyst control centre and change auto-brightness settings, but I do not have that program installed.

 

Anyone able to advise??

 

ndonaldson2912

 

 



BC AdBot (Login to Remove)

 


#2 Yazzafox

Yazzafox

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 13 May 2016 - 08:12 AM

Heya!

 

I encountered exactly the same problem a while back. In my situation, having catalyst control centre installed caused all sorts of issues with my drivers, so I uninstalled it.

 

I worked around the error message with a cheeky 'fix' of renaming the atibtmon-exe file. It effectively removed it from operation, without deleting it 'just in case'. I renamed it "2atibtmon" so that I could easily revert it if it caused any other issues. To date, everything has been flawless.

 

As far as I'm aware, its only purpose is to dim the screen as a powersaving feature when running from the battery, which catalyst control centre seems to utilize more efficiently.

 

If a more professional solution isn't suggested, it might be an avenue worth exploring.



#3 ndonaldson2912

ndonaldson2912
  • Topic Starter

  • Members
  • 234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:15 PM

Posted 13 May 2016 - 08:33 AM

Could you tell me how to rename the file?

#4 Yazzafox

Yazzafox

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 13 May 2016 - 08:46 AM

The easiest way that I tend to use, is to just type the filename into the search bar beside your start button. If it shows in the list, right click it and "open file location". It should open a window with the file highlighted.

 

If this method doesn't work, you can click Start > File Explorer. A new window will open, and on the left hand side, you should see "This PC". Click that, and journey through the folders in order of your file's location. In your case, it should be - This PC > C: (local disk?) > Windows > System32.

 

(If you can't see it, it may be a hidden file. You can view hidden files by opening File Explorer Options, click on the View tab, and under "Hidden files and folders", click to highlight "Show hidden files, folders and drives" and hitting Apply.)



#5 ndonaldson2912

ndonaldson2912
  • Topic Starter

  • Members
  • 234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:15 PM

Posted 13 May 2016 - 08:48 AM

Messed about with a few options and I think I have it sorted without having to rename any files...

Right click on [charge icon] in taskbar and select "power options"

to the right of the currently selected power plan click on "change plan settings"
Then click "change advanced power settings"

in drop down list select which ever selection has "[Active]" attached to it.
Then scroll to bottom of list where you should find a listing "ATI Graphics Power Settings"

Expand this listing and its inner "ATI PowerPlay Settings" until you see the "On Battery: and Plugged in:" options are shown.

change the "On battery:" option to "Maximum Performance" and click "OK"

I reset the laptop with the power cable out and got no runtime error. And no error if the cable is pulled out when the laptop is on!! :-)

#6 Yazzafox

Yazzafox

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 13 May 2016 - 08:54 AM

Nice. Thank you for going into detail about how you fixed it!

 

I never knew the power options had a graphics power setting. Nicely done, ndonaldson2912!



#7 Jocky_24

Jocky_24

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Blairgowrie, Perthshire & Kinross
  • Local time:05:15 PM

Posted 27 June 2017 - 10:24 AM

I know this is an old post, like a year old but I just ran into this error for the first time today on a customers computer and although this isn't a fix, it is a workaround. First time I've ever seen the Microsoft forums actually come up with a valid answer :P  but I'll leave the link here for anyone else that needs it.

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/fix-for-atibtmonexe-error-after-windows-10-update/e0d13a6e-33f5-423f-b264-4aca8f00a177

 

Cheers guys.

 



#8 Lvlpost

Lvlpost

  • Members
  • 77 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:hawai
  • Local time:12:15 AM

Posted 27 June 2017 - 09:48 PM

Right click on [charge icon] in taskbar and select "power options"

 

to the right of the currently selected power plan click on "change plan settings"

 

Then click "change advanced power settings"

 

in drop down list select which ever selection has "[Active]" attached to it.

 

Then scroll to bottom of list where you should find a listing "ATI Graphics Power Settings"

 

Expand this listing and its inner "ATI PowerPlay Settings" until you see the "On Battery: and Plugged in:" options are shown.

 

change the "On battery:" option to "Maximum Performance" and click "OK"

 

This may reset your default screen brightness to %100 on battery but you can manual set to anything lower in the "change plan settings" area and the screen with dim to entered value as it should and without atibtmon.exe error and no more error upon waking from sleep mode, which apparently didn't actually work at all with out this fix.

 

again this worked on a Compaq cq62 and seems it should work on any other with ATI mobility radeon chipsets






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users