Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Server 2012 r2 Opening firewall on remote Server Core machine for MMC


  • Please log in to reply
2 replies to this topic

#1 anouri

anouri

  • Members
  • 3 posts
  • OFFLINE
  •  

Posted 12 May 2016 - 01:44 AM

MCSA student here. I'm having some difficulty with this one.

Same subnet and workgroup.

Server 1 is a physical 2012 R2 server. Server 2 is a Server Core running as a VM on a workstation.

As part of an exercise, I added server 2 to All Servers on Server 1's Server Manager. I logged in and saved login info via "Manage As" and via right clicking Server 2 in All Server I can perform all tasks except for "Computer Management". Now here comes the part where I must open up the firewall ports on the remote machine (Server 2) to allow remote Computer Management access.

My book provides these steps to perform the first part, which is to allow me to use one MMC snap-in (Adv. Firewall) remotely so I can open up the rest of the firewall ports. I figure it's easier to do this because doing via Server Core CLI (cmd or powershell) is very tedious less efficient.

Here are the instructions: https://i.sli.mg/XpPcrK.png -Mind you, I ran the command listed in step # 3 by opening powershell via All Servers, right clicking Server 2's powershell and the command seems to have gone thru (no error).
The process fails for me at step 5, where I'm to add the MMC Adv. firewall snap-in. I get this error: https://i.sli.mg/ZDuaF9.png

Any idea of what I'm doing wrong or what the issue is here? I appreciate any help, thanks.



BC AdBot (Login to Remove)

 


#2 JohnnyJammer

JohnnyJammer

  • Members
  • 1,117 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:QLD Australia
  • Local time:04:30 AM

Posted 12 May 2016 - 07:27 PM

I would use WMIC and NETSH

So something like so should work, i havnt tested it but it should

wmic /node:ServerCoreIPorName_Here process call create "netsh advfirewall set icmpsetting 8 enable"

Change ServerCoreIPorName_Here to that of the IP or targetname (Netbios name) of the server

 

More references, old versus new netsh commands

https://support.microsoft.com/en-us/kb/947709


Edited by JohnnyJammer, 12 May 2016 - 07:27 PM.


#3 sflatechguy

sflatechguy

  • BC Advisor
  • 2,226 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:30 PM

Posted 15 May 2016 - 10:34 AM

The second error message indicates it's a permissions issue. Is the domain account you are using a member of the Administrators group on the Server Core server?

 

Have you tried running the PowerShell commands directly on the Server Core server? RDP into that server, and at the command prompt enter start powershell.exe; you can also try runas /administrator powershell.exe to make sure it is running with elevated privileges. This will open a second, PowerShell terminal window in the RDP session. Run the command from there.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users