Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problems installing service pack 1; installhelper.dll missing


  • Please log in to reply
2 replies to this topic

#1 Mongrel714

Mongrel714

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 03 May 2016 - 12:46 PM

Hey guys, I really hope you can help me with this as it's a very frustrating problem.
 
The long and short of it is I always get an error message (failed to initialize or something like that) when trying to download Windows Service Pack 1, and whenever I turn on my computer I get an error message saying installhelper.dll could not be found. I'm not sure if they're related, but they seem like they might be.
 
I've had this issue for a long long time, ever since one of the many updates I installed for Windows 7 since getting the computer years ago. I mostly just ignored it because it didn't seem to be directly affecting anything (though my computer is running slowly, which the internet tells me may be related to one or both of these issues), but now I'm trying to install the Overwatch beta (new game) and it's telling me I don't meet the system requirements because I don't have Windows Service Pack 1 installed. =(
 
When I try to install the service pack, it usually takes a while (no surprise really, it says it can take 30 mins), then asks me to restart my computer. When I do, it attempts to configure the update, but at around 13% or so it always says something to the effect of "configuration failed to initialize, restoring previous settings." when my computer boots back up I get an error message telling me that installhelper.dll could not be found, and if I check it tells me the service pack failed to install. The windows update log it has this to say about why it did not install:
 
Error details: Code 80070490 (which if I click more details, says that it means a file (CBS Manifest) that's needed to install updates is corrupt). I have tried repairing the corrupted CBS Manifest via Command Prompt, but though the scan I did (can't remember the command, got it from a guide on repairing CBS Manifest) said it fixed corrupted files I had the same issues when I tried to install the service pack. Checking the log on why that install failed yields the same error (corrupted CBS Manifest). 
 
I have also tried running the Windows Update Troubleshooter, and after doing so there were 2 important updates I needed to install (rather than just the service pack). I'm installing them now but don't have very high hopes. (Edit: the service pack failed to install again. The other essential update (a definition update for Windows Defender) installed successfully)

Does anyone have any suggestions on how to tackle this problem? It's really bugging me =(

Edit: my brother told me that you can upgrade windows 7 to windows 10 for free, I'm trying that now to see if it fixes the issue.
 
Here's my computer info copied down from my system specs:
 
Windows 7 professional 64 bit
Processor:  I have an Intel® Core™ i7 CPU  950  @  3.07 GHz
3.07 GHz
Installed memory (RAM): 8.00 GB
System type: 64 bit operating system
 
If you need more info just ask, though you might need to tell me where to find it.

Edited by Mongrel714, 03 May 2016 - 01:37 PM.


BC AdBot (Login to Remove)

 


#2 Mooseby

Mooseby

  • Members
  • 276 posts
  • OFFLINE
  •  
  • Local time:05:01 AM

Posted 03 May 2016 - 04:47 PM

Hello,

Do you have the OEM Windows install disk? It might be you could repair the missing files from there in the Windows Recovery Enviroment (I have Googled how to extract the CABs, rename the old ones and write the new one).



#3 Mongrel714

Mongrel714
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:06:01 AM

Posted 10 May 2016 - 01:41 PM

Hey, sorry for not posting this sooner, but upgrading to Windows 10 fixed all my issues. 

Thank you for the reply Mooseby.

Mods can close this thread now, my issues were solved.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users