Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

problem getting windos to mount in rw with ubuntu


  • Please log in to reply
6 replies to this topic

#1 lacey16

lacey16

  • Members
  • 62 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 28 April 2016 - 07:58 AM

Hello all.  brilliant site this.

 

This one is a little different. I did a clean install of windows 10 followed by Ubuntu. All fine. Dual Boot ok. ubuntu partitions on SSD drive & windows on SATA drive. A few days later intermittent power surges and cuts trashed win 10. It could not be fixed by recovery or repair so I had to reinstall. It dual boots fine except that ubuntu will only mount windows as read only.
The problem is a 500mb unallocated partition at the beginning of the NTFS /C partition. because of this Ubuntu thinks that the windows partition is not ready and will therefore mount it in read only. I created this partition because of a windows error claiming no space for system reserved. Then they failed to use if for their bootloader UGH

 

Anyway I tried creating a simple volume in the unallocated space, and assigning a drive letter which I hoped would allow me to delete the partition totally but no good. As far as I can tell the windows disk manager only permits extending a partition that is behind the /C volume in order to prevent messing up the MBR I have 318GB of unallocated space to the right of the ntfs partition, But all i want to do is get rid of the partition in front of the ntfs partition either by deletion or merging with the /C partition. Is it possible to move partitions please or to get windows to input their bootloader into the 500mb unallocated partition or mount the windows partition and direct ubuntu straight to it.  All suggestions, ideas, and replies very welcome  thanks  happy to provide as much info as needed

All suggestion , ideas, replies very welcome. Thanks.
 

 

 



BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,100 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:07:22 AM

Posted 28 April 2016 - 08:29 AM

Have you turned fast boot off in Windows?

 

 

 

To turn it off, open start screen and enter Power Options. Click Settings tab in the right side and select, Change what the power buttons do from the left side. Once the System Settings window is open, scroll down to the Shutdown settings section and uncheck the Turn on fast startup option

 

Fast-Startup.jpg


Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!


#3 lacey16

lacey16
  • Topic Starter

  • Members
  • 62 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 28 April 2016 - 08:39 AM

Hi  yes before I installed windows I disabled secure boot and fast start up in the bios.  After installation I disabled hibernation and sleep and deleted the hiberfile.

 

In fact the only options shown when shutting down windows are  "shut down and restart".   I did NOT disable CSM so windows should be booting in efi mode

 

Thanks for your reply and suggestions.



#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:05:22 PM

Posted 28 April 2016 - 08:48 AM

You still have to disable the "Fast startup" after installing Windows that NickAu shows in his post above. If you don't do this Linux will still think the drive is in use by Windows, which it technically is.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#5 lacey16

lacey16
  • Topic Starter

  • Members
  • 62 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 28 April 2016 - 10:57 AM

Ok will check when im on windows pc but im pretty sure that I disabled everything I could ref:  fast startup secureboot sleep. hibernation. I did have this problem before when hibernation was the poblem and Ubuntu actually said cant mount disk   windows is hibernated.  This time it is saying disk not ready or not there.   Windows is usually installed before ubuntu so ubuntu can overwrite window boot manger with grub2 .  Of recent years Linux has developed grub to be compatibile with efi.  After install ubuntu failed to boot.  Used Ubuntu boot repair disk to fix grub. both systems boot ok. Grub will only mount the windows partition in read only because the first thing it sees when mounting is the 500mb unalloacted partition before it hits the boot manager   If I could direct grub to go immediately to the windows partition there would be no problem as the grub bootloader is there.

 

In the grub menu there are 2 options to boot windows and both work.  I think one has been written in by grub2 boot repair and the other is the windows own boot loader.   I can reinstall windows again but im concerned that it will again request space for system reserved and I just end up again with the unallocated space in front of the windows partition.

 

This is only what I think is happening and I could be entirely wrong but i do appreciate your help.    Thanks 



#6 lacey16

lacey16
  • Topic Starter

  • Members
  • 62 posts
  • OFFLINE
  •  
  • Local time:09:22 PM

Posted 03 May 2016 - 06:17 PM

Hi sorry for the long delay. Got waylaid with printer and repository problems in Ubuntu 16.04lts  Now resolved.

 

On bootup the grub menu appears with,  Ubuntu : sda1 windows bootloader : sdb2 windows bootloader.   When installing windows a message demanded space for system reserved. I thought this meant that windows required a partition for the its boot init files but it didnt as it would appear that the boot loader is on the ntfs primary partition sdb2 and when i did the boot repair grub installed bootup on sda1. Hence both options appear on the grub menu

 

I dont know if its possible for me to create the 500mb partition as primary, give it a drive letter and copy the boot files to that partition.  Would setting windows as the first and default option in grub make any difference.

yes fast boot was definitely disabled with all the other relevant features in windows. Windows does not hibernate. When shut down it powers off completely. Error message at grub:

 

sudo mount -o rw /dev/sdb2 /mnt

Mount is denied because the NTFS volume is already exclusively opened.

The volume may be already mounted, or another software may use it which

could be identified for example by the help of the 'fuser' command.

 

 how to use the fuser command would be much appreciated.

 

 

Deleting the freespace 500mb partition to give grub immediate access to sdb2 boot files on ntfs partition would be the ideal solution but i cant delete it.

 

/etc/fstab: static file system information.

#

# <file system> <mount point> <type> <options> <dump> <pass>

 

#Entry for /dev/sda2 :

UUID=c0d626a9-d88d-4023-bf44-4bd62f1e4232 / ext4 errors=remount-ro 0 1

#Entry for /dev/sda6 :

UUID=89d8ca57-ce09-40e5-a95e-a80cf4088897 /home ext2 defaults 0 2

#Entry for /dev/sda1 :

UUID=2826E9C826E9975A /media/System_Reserved ntfs defaults,nls=utf8,umask=0222 0 0 

#Entry for /dev/sdb1 :

UUID=62DA972ADA96F98D /media/System_Reserved_ ntfs defaults,nls=utf8,umask=0222 0 0

#Entry for /dev/sdb2 :

#Entry for /dev/sda5 : 

UUID=2a1f8105-5cd2-480e-a5c6-5ff9d39efd97 none swap sw 0 0

 

 

UUID=105EDF9E5EDF7B44 /media/sdb2 ntfs defaults,nls=utf8,umask=0222,noauto,ro 0 0  

 

some options that may work from 

mount -n -o remount,rw / dpkg --configure -a

One can change the type of mount containing the directory dir:

mount --make-shared dir

mount --make-slave dir

mount --make-private dir

mount --make-unbindable dir

One can change the type of all the mounts in a mount subtree

containing the directory dir:

mount --make-rshared dir

mount --make-rslave dir

mount --make-rprivate dir

 

mount --make-runbindable dir  

 

fstab -l  

 

 Device Boot Start End Blocks Id System

/dev/sda1 * 2048 1026047 512000 7 HPFS/NTFS/exFAT

/dev/sda2 1026048 176807935 87890944 83 Linux

/dev/sda3 176809982 231495679 27342849 5 Extended

/dev/sda5 176809984 196339711 9764864 82 Linux swap / Solaris

/dev/sda6 196341760 231495679 17576960 83 Linux

 

 

/dev/sdb2 * 1026048 308226047 153600000 7 HPFS/NTFS/exFAT

 

 

please notice boot sda1 & sdb2

 

and this from a windows 10/microsoft forum:    Problem:

Windows setup created a System Reserved partition and installed the booting files on it. As a result, booting directly from the Windows partition is not possible. My problem is the opposite. ubuntu is booting from the window partition on sdb2

 

All suggestions welcome     Thanks


Edited by lacey16, 03 May 2016 - 06:25 PM.


#7 Rocky Bennett

Rocky Bennett

  • Members
  • 2,631 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:03:22 PM

Posted 04 May 2016 - 05:58 AM

Have you turned fast boot off in Windows?

 

 

 

To turn it off, open start screen and enter Power Options. Click Settings tab in the right side and select, Change what the power buttons do from the left side. Once the System Settings window is open, scroll down to the Shutdown settings section and uncheck the Turn on fast startup option

 

Fast-Startup.jpg

 

 

A couple of little problems here. There are no options on the right side of the screen, all of the options are on the left side of the screen. Also my Turn On Fast Start Up is checked but it is grayed out, I can not uncheck it. Of course I have been multi-booting for a long time without any problems, but I wanted to check this little feature that you are talking about.


594965_zpsp5exvyzm.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users