Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Thunderbolt drives not recognized - Asus motherboard issue?


  • Please log in to reply
No replies to this topic

#1 frenchmonkeys

frenchmonkeys

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:45 AM

Posted 27 April 2016 - 12:02 PM

I have a Windows 10 machine built around an Aus Maximus V Extreme - other specs below if required.

 

I have a couple of Synology NAS Devices, and a couple of G-RAID Thunderbolt drives for storage.  I used one Thunderbolt drive for a while and was chuffed with the speed.  Upgraded to Windows 8.1 and started having problems - the drive would only occasionally show up (and by that I mean, not visible as a drive in Windows Explorer, not present in Disk Manager, not shown in Thunderbolt software - simply not recognized.).  It's an 8TB unit incorporating 2x 4TB drives, which I used as JBOD for a while.  Occasionally, only one of the disks would be present. I went through G-Technology support - they sent me a new power supply and Thunderbolt cable, and the drive was then visible.  I removed all data, and set the drive aside. Since then I upgraded to Windows 10.  Last week I found my two NAS devices were getting rather full, so decided to reinstate my G-RAID 8TB, and also bought a new 12TB G-RAID, planning to chain these devices.  I connected my 8TB drive and copied about 1TB of data from one NAS to it.  I came to it a couple of days later to continue re-organizing data, and the drive doesn't show up.  So I tried another new power supply and thunderbolt cable courtesy of G-Technology support, but it still didn't show up.  Neither does the new 12Tb drive, but that one also has a USB 3 connection, and works perfectly when connected through USB 3.

 

At this point, I'm convinced the problem lies somewhere between the Thunderbolt port on my Maximus V Extreme motherboard and Windows 10.  The BIOS on the motherboard is all set correctly with the port enabled.  I checked device manager and saw a problem I'd not noticed previously:

 

the PCI express root port 8 device had an exclamation mark, and on further inspection showed the following issue:

 

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31) The specified request is not a valid operation for the target device. 

 

A-ha!  So I tried uninstalling the driver (and removing it) and updating it.  No change.  Then I looked for UpperFilters and LowerFilters settings for this device.  None present.  There are some set for other devices, but they do not appear to be linked to the error shown in Device Manager.  

 

OK, so now I'm stumped.  The system was upgraded rather than freshly installed, and there were almost certainly remnants of old code floating around, so I figured a fresh reinstall couldn't hurt.  Just done that, and have removed all unnecessary internal and external devices from the system thinking that if one of those devices might be the culprit, I would discover it as I went along installing one item at a time - the system is fully loaded and I use it for work and play.  Unfortunately, the error is still shown in Device Manager after my fresh installation to a newly created and formatted partition, and Thunderbolt devices still don't show up.  I feel it's likely the two issues are related, but I don't know what this PCI system device/driver does, so can't say for sure, but I know it didn't show up about a month ago, and also that a couple of weeks ago when I first connected the Thunderbolt drive it was working under Windows 10.

 

I'm reasonably tech savvy, but not certified in any recent Windows versions, and completely stumped.  I really need to get this working as soon as possible.  I've tried Asus support and a week later have received no response at all. G-Technology have exhausted what they can do, and I do ffel that having the same issue with the new 12TB drive, but proving it works via USB3 pretty much rules out a problem with the devices themselves.  All components have the Thunderbolt symbol, and are therefore the correct components and must therefore surely meet Windows 10 HCL requirements.

 

I'd be ridiculously grateful for any help.  Thanks in advance.

 

 

Main System Specs: 

Motherboard: Asus Maximus V Extreme, CPU: Core i7-3770K @: 3.5GHz, Cooler: Corsair H80i, SSD: Samsung 840 Series 512mb, Memory: 32Gb, Graphics: 2x NVidea Geforce GTX Titan, Monitor: 2x NEC Spectraview Reference 301, Keyboard: Corsair Vengeance, ask if you need any more specifics.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users