Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't open ports in my D-Link DIR-825


  • Please log in to reply
5 replies to this topic

#1 Junker92

Junker92

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:10 PM

Posted 26 April 2016 - 01:48 PM

Hi,

It seems I can't open ports in my router (D-Link DIR-825). I have tried many different port numbers on both Port Forwarding and Virtual Server but the ports I open are closed according tohttp://www.yougetsignal.com/tools/open-ports/

For example I have opened port 8888 (both UDP and TCP, addressed to my local IP 192.168.0.107). This is my Apache port (configured with MAMP Pro) and I can access that port typing localhost:8888 in Google Chrome but not typing myexternalip:8888 when connected to another network (my iPhone's mobile network for example).

I have no software firewall or antivirus program installed (MacBook Pro, 2010, Yosemite) and I'm not behind a Carrier Grade NAT.



BC AdBot (Login to Remove)

 


#2 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:01:10 PM

Posted 26 April 2016 - 02:44 PM

You need to forward the ports through the router and allow them to pass through the firewall on the MacBook to allow Apache to work. Even though you did not install a firewall there should be the standard one activated on the Mac. Check out this link for how to unblock an application via the OS X firewall.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#3 Junker92

Junker92
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:10 PM

Posted 26 April 2016 - 02:55 PM

You need to forward the ports through the router and allow them to pass through the firewall on the MacBook to allow Apache to work. Even though you did not install a firewall there should be the standard one activated on the Mac. Check out this link for how to unblock an application via the OS X firewall.

My OS X firewall is not enabled.



#4 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:01:10 PM

Posted 26 April 2016 - 03:02 PM

Probably not the best idea. I would enable it and then allow apache through.

 

Regardless if you do that or not... check your router settings and make sure you port forward the specific ports you want and have both TCP and UDP forwarded. Unless you know it uses TCP over UDP or vice versa.

 

That should be all you need to allow Apache through. If that isn't it... I would double check the Apache configuration. Something could be slightly off not allowing you through.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +


#5 Junker92

Junker92
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:07:10 PM

Posted 26 April 2016 - 03:50 PM

I got it working now by changing UDP- and TCP Endpoint Filtering to "Endpoint Independent" in the router config. I can now reach the ports I've opened in Port Forwarding and I can access my Apache server with "my.external.ip:8888" from other networks.

How is this solution regarding security risks?



#6 DeimosChaos

DeimosChaos

  • BC Advisor
  • 1,420 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:United States, Delaware
  • Local time:01:10 PM

Posted 27 April 2016 - 08:34 AM

Glad you got it working!

 

As far as security, if you don't have your OS X firewall turned on, I would do that. It will block anything that is not specifically allowed, so it gives you some security on your Mac there. Your router has a firewall built in as well so that will be the first layer of defense. If you are wanting to run the Apache server all the time, I would consider getting a second computer (you could also host an Apache web server on a raspberry pi and do this) and put it in a DMZ area.

That will make it so that if someone attacks the server it can't talk back to your internal network and let them gain access to that as well.


OS - Ubuntu 14.04/16.04 & Windows 10
Custom Desktop PC / Lenovo Y580 / Sager NP8258 / Dell XPS 13 (9350)
_____________________________________________________
Bachelor of Science in Computing Security from Drexel University
Security +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users