Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Changing the time in Ubuntu 16.04


  • Please log in to reply
3 replies to this topic

#1 Rocky Bennett

Rocky Bennett

  • Members
  • 2,527 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:04:30 AM

Posted 22 April 2016 - 05:39 AM

Does anybody know how to change the time from UTC to local on Ubuntu 16.04? It does not seem like the setting is stored in the rcs file. I have done this on previous editions of Ubuntu but I am having problems with this new version.

 

 

http://askubuntu.com/questions/127993/how-do-you-get-permission-to-save-rcs-after-setting-utc-no


594965_zpsp5exvyzm.png


BC AdBot (Login to Remove)

 


#2 mremski

mremski

  • Members
  • 490 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NH
  • Local time:06:30 AM

Posted 22 April 2016 - 07:09 AM

You mean the hardware clock?  The one you set through BIOS?


FreeBSD since 3.3, only time I touch Windows is to fix my wife's computer


#3 jojarth

jojarth

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:04:30 AM

Posted 22 April 2016 - 08:14 AM

I had this problem this morning too. After some google searches, I came across this:

You can set the hardware clock time standard through the command line. You can check what you have set to use by:
$ timedatectl | grep local
The hardware clock can be queried and set with the timedatectl command. To change the hardware clock time standard to localtime, use:
# timedatectl set-local-rtc 1
If you want to revert to the hardware clock being in UTC, do:
# timedatectl set-local-rtc 0

This worked for me! I ran the timedatectl set-local-rtc 1, rebooted (I also had to reset my BIOS time when I rebooted).

 

This fix was thanks to muru on the ubuntu forums, and it looks like he got the fix from the Arch wiki.

 

I hope this helps you like it helped me!

 

Source:

http://askubuntu.com/questions/169376/clock-time-is-off-on-dual-boot

https://wiki.archlinux.org/index.php/Time#Time_standard



#4 Rocky Bennett

Rocky Bennett
  • Topic Starter

  • Members
  • 2,527 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Mexico, USA
  • Local time:04:30 AM

Posted 22 April 2016 - 12:37 PM

Thanks guys. I have since found the answer over at the Ubuntu forum where several people were experiencing the same phenomenon. The answer is that editing the rcs file no longer applies in systemd and the setting is now stored in the crontab file. No problem now that I know where the setting can be modified.


594965_zpsp5exvyzm.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users