Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Update not working on fresh Vista Home Premium install


  • Please log in to reply
3 replies to this topic

#1 beardit

beardit

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 05 April 2016 - 10:30 AM

Hi all

 

Done a fresh install of Vista Home Premium SP2 on an old Sony Vaio laptop.  After activation I just can't get Windows Update to download anything apart from the latest Windows Update Client There's no error message, just "checking for updates" constantly.   It's been running for over 24 hours now with no progress.

 

Considering this is a fresh install - any ideas?

 

Cheers!



BC AdBot (Login to Remove)

 


#2 beardit

beardit
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:11 AM

Posted 06 April 2016 - 06:14 AM

UPDATE

 

For anyone that's interested the updates have now arrived after almost three full days of checking for updates.  It appears my new ISP gives piss poor connection speeds.



#3 Abzyx

Abzyx

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:08:11 PM

Posted 06 April 2016 - 08:54 PM

UPDATE

 

For anyone that's interested the updates have now arrived after almost three full days of checking for updates.  It appears my new ISP gives piss poor connection speeds.

Don't blame your ISP, this is Microsoft's fault, and has been reported by Vista and Windows 7 users since August 2015 (right after the Windows 10 release, coincidence?) There have been a large number of updates since SP2 was released in 2009, and Patch Tuesday is next week, so be prepared for more of the same. Once the system is fully updated and desired software is installed, you should make an image because "extended support" ain't what it used to be.



#4 Katrah

Katrah

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:08:11 PM

Posted 27 April 2016 - 07:16 AM

UPDATE

 

For anyone that's interested the updates have now arrived after almost three full days of checking for updates.  It appears my new ISP gives piss poor connection speeds.

Thank you so much for updating this. I have the exact same problem. Re-installed a fresh Vista Home Premium on my daughter's PC and it's been checking for updates for nearly 24 hours. I've never seen anything like this and was starting to think something was wrong. I guess we'll just keep waiting it out. Thanks again!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users